Infiniti FX Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
68 Posts
Discussion Starter #1
I recently had my dealer do an XM install ( in retrospect, I think I woulda, coulda, shoulda done this myself, but I didn't know about this great site until after I bought the vehicle with the "we owe" tuner). Anyway, here's my problem. Despite all kinds of fiddling with the right tuning knob (the one that controls bass, fade, etc) to set the display options, my display will show the word "antenna" when in satellite mode. If I switch channels it will display the station channel, station name and artist for 1-2 seconds but then reverts back to "antenna." This is vexing. Everything else works fine. Anybody have a similar experience? (I do not have the Tech package.)
 

·
Registered
Joined
·
54 Posts
does the antenna have a clear view of the sky? if it does then take it back to the dealer... it coudl just be a loose connection between the antenna and the "xm brain"... it could also just be a bad unit... i have read a lot of about problems with the xm...and my fx had the same problem... (granted my fx leaks water amongst a dozen other problems) but it should be an easy fix for your dealer
 

·
Registered
Joined
·
4,983 Posts
My XM micro ant. can't even SEE the sky, that's the way I like it, uh-huh, un-huh, but works fine - stealth install / under black spoiler. See pics.
 

·
Registered
Joined
·
54 Posts
PINITI-FX said:
My XM micro ant. can't even SEE the sky, that's the way I like it, uh-huh, un-huh, but works fine - stealth install / under black spoiler. See pics.
yea, i saw yours...thats awesome... but its getting the signal through the plastic right? when i said view of the sky i meant not under a big concrete bridge or in the garage
 

·
Registered
Joined
·
4,983 Posts
sorry, gotcha, yeah there are times when under a very long overpass, bridge or tunnel it goes bye-bye for a sec. or so, then comes back, good thing I know the words :D
 

·
Premium Member
Joined
·
68 Posts
Discussion Starter #7
Anyway, here's my problem. Despite all kinds of fiddling with the right tuning knob (the one that controls bass, fade, etc) to set the display options, my display will show the word "antenna" when in satellite mode.
My dealer seems to think the problem is in the antenna wiring. Will take it in next week for a look-see.
 
1 - 7 of 7 Posts
Top