Infiniti FX Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
my infinity Fx 35 of 2005 engine stops while driving and the Slip and VDC light gets one, then I have to try and force the start the car back multiple times before the engine can start back and I noticed that when I start back the car if the VDC and SLIP lights are one then the engine doesn't stop again when I park for some time its start normally and no light is on, and the then it can happen anytime again for the engine to stop while I drive.
please help
any solution ?
 

·
Registered
Joined
·
18 Posts
my infinity Fx 35 of 2005 engine stops while driving and the Slip and VDC light gets one, then I have to try and force the start the car back multiple times before the engine can start back and I noticed that when I start back the car if the VDC and SLIP lights are one then the engine doesn't stop again when I park for some time its start normally and no light is on, and the then it can happen anytime again for the engine to stop while I drive.
please help
any solution ?
Same thing for me. First time was last summer. Limped home. Then much more frequently starting in late summer and continuing. Shut off and restart fixes it. On a couple of occasions, it did this while driving at speed, but mostly when idling (waiting in a pickup line, for instance) or starting up. I'm not driving much, so I've lived with it, but what I read here makes it seem like a cam sensor is misbehaving. I think the shut down is for engine protection.

One of these days I'll get the codes read to confirm.
 

·
Premium Member
Joined
·
1,822 Posts
It could very well be one or both of your cam sensors but you will have to get the codes to determine this. I'm not sure if a crank sensor puts the vehicle into limp mode but it could be that as well. Also could be MAF related as well. Cleaning may help here.
 
1 - 3 of 3 Posts
Top