Infiniti FX Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I just picked up an 09 FX35 yesterday, and all dashboard lights were fine driving home. Tonight, I just noticed all of the lights behind the radio, climate control, purple dial lights were out. The weird thing is that the Clock light, and ash tray light still works. All of the button lights are out though.

Does anyone know what specific fuse this is? I've pulled almost all of the fuses, and they all looked fine.

I've done a bunch of searches, but couldn't find the answer, hoping someone can help.

Thanks in advance.
 

·
Registered
Joined
·
99 Posts
Screw That! I would bring it back to where it was purchased and make them fix it....at least this was its document if its something more then a fuse
 

·
Premium Member
Joined
·
4,763 Posts
Sorry, I don't know the fuse for that. John would know. But I agree with the last poster, take it back to the dealer you bought it from and make them fix it.
 

·
Premium Member
Joined
·
10,642 Posts
The manual is very confusing on the 09s. I am seeing fuses 10 and 19 in the fuse box, fuse 44 in the IPDM under the hood. Check those.
 

·
Registered
Joined
·
111 Posts
All of sudden, I have no illumination on the dashboard, clock, glove compartment and steering wheel control (All others lights are normal). The LCD does not repsonse to auto day light control (it doesn't dim at night). I have checked the fuse box on the driver's side and and the one in the battery compartment and found none blown. Is there anything I can do before bring it to the dealer? My warranty was just expired last month :(. Any helps greatly appreciated
 

·
Premium Member
Joined
·
2,732 Posts
Mrlover said:
All of sudden, I have no illumination on the dashboard, clock, glove compartment and steering wheel control (All others lights are normal). The LCD does not repsonse to auto day light control (it doesn't dim at night). I have checked the fuse box on the driver's side and and the one in the battery compartment and found none blown. Is there anything I can do before bring it to the dealer? My warranty was just expired last month :(. Any helps greatly appreciated
there's a second fuse box in the battery compartment. Check that one too just in case.

Does pressing the Day/Night button cycle the screen brightness? It'll stay on the one you choose if you press the button. Cycle it once and it should return to auto switching.
 

·
Premium Member
Joined
·
10,642 Posts
Did you dim the lights down accidentally?
 

·
Premium Member
Joined
·
10,995 Posts
aiya said:
Does pressing the Day/Night button cycle the screen brightness? It'll stay on the one you choose if you press the button. Cycle it once and it should return to auto switching.
I was thinking the same thing...
 

·
Premium Member
Joined
·
10,995 Posts
aiya said:
Great....and twisted...minds think alike.
Oh my... now I'm worried about you... :lol:
 

·
Registered
Joined
·
111 Posts
Pressing the the Day/Night button cycle the day night brightness, but it didn't change to auto. I did check the fuse box in the battery compartment, but could not find any blown fuse. I should also mention that there is no A/t (gear box) illumination. I have the electrical schematic of the whole illumination thing, but its too complicated for me to understand anybody interested? thanks for all the helps...and welcome more suggestion


Thanks
 

·
Premium Member
Joined
·
10,995 Posts
Mrlover said:
I did check the fuse box in the battery compartment, but could not find any blown fuse.
Did you check BOTH fuse boxes? There's one BEHIND the battery that's a bit of a pita to get to...
 

·
Registered
Joined
·
111 Posts
DatMan said:
Mrlover said:
I did check the fuse box in the battery compartment, but could not find any blown fuse.
Did you check BOTH fuse boxes? There's one BEHIND the battery that's a bit of a pita to get to...
I've just checked that fuse box, but the only fuse related to this was the DTRL and I don't have any problem with my DTRL. All my lights are normal other then, dashboard illumination, steering wheel control, clock, A/T (gear box), and glove compartment. Any more suggestion is greatly appreciated.

thanks
 

·
Registered
Joined
·
111 Posts
I only checked the one beside the battery and the one on the driver's side next to the manual brake. I didn't check the one behind the battery, the IPDM. It turned out that It was fuse #71 in IPDM behind the battery. Problem solved. Thanks everyone.

The services manual worth every penny.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #15
So after the car being at the dealer shop for 3 days, they had to replace something called the Faceplate. I don't know, but it solved the issue.

But another problem came up.

So when I checked the fuses, I never checked the one behind the battery either. And I know for a fact that my engine cover was on before going to the dealer. A few weeks past, and I opened my hood, to my surprise, NO ENGINE COVER! This dealer is telling me they don't need to take the cover off to get to the other fuse box. Is this true?

Either way, someone over there forgot to put it back on, and they're saying they didn't do it. ARRGGGGG!
 

·
Premium Member
Joined
·
10,995 Posts
papa_giorgio said:
This dealer is telling me they don't need to take the cover off to get to the other fuse box. Is this true?
Yeah... no need to take off the engine cover for that... you just need to take off the battery cover and then reach back...
 
1 - 17 of 17 Posts
Top