Infiniti FX Forum banner

1 - 20 of 43 Posts

·
Premium Member
Joined
·
10,642 Posts
Discussion Starter #1
The wife called me today and said when she started the FX up, the gas gauge read dead empty. She knew she had at least 1/4 tank. On the fuel economy screen it showed 100 miles to empty. So, knowing the sometimes wackiness of these "technologically advanced" vehicles, and hearing my daily stories about crazy electronics in general, she turned off the FX and started it back up, and the gauge then read fine. Sure is strange.
 

·
Registered
Joined
·
121 Posts
Johnmax

Mine did something strange as well. I was stuck in traffic and moving less than five miles an hour. The My milage till empty dropped over 150 miles. It stayed there until i hit the reset. I think the computer in our cars get confused when stuck in traffic. Does this happen anyone else???

Vince
2005 FX35 - Stock for now.
 

·
Premium Member
Joined
·
10,642 Posts
Discussion Starter #3
Did it again a few times tonight. The wife says it did it the first time when it got to 1/4 tank, and tonight once we hit 1/4 tank it did it again a couple of times. I'd come out of a store and gauge read empty, but it was 1/4 when we stopped. Finally I just drove some knowing there was gas in there, and slowly it crept from empty up to the quarter mark. Ugh. Looks like a trip to the dealer. :?
 

·
Premium Member
Joined
·
10,642 Posts
Discussion Starter #4
Always does it now once the tank gets to 1/4. Called the dealer and he said he would order a new fuel sender. Kinda strange that they would order it before checking it out, so I asked and he said that he has seen it before. Funny that none of us has.
 

·
Premium Member
Joined
·
10,642 Posts
Discussion Starter #6
I don't see one that for that problem. Only two for fill up issues.
 

·
Registered
Joined
·
383 Posts
i have the same prob i guess i'll call now thats its a known prob
 

·
Registered
Joined
·
13 Posts
I had the problem of the gauge showing empty with approx 7 gals of gas left in the tank. If I kept driving, the needle would actually start to rise again. I did research the TSB, which had to do with incorrect fuel gauge and recommended changing the sensors.

My car was fixed under warranty. Since the fuel tank on the FX is shaped like a pair of saddlebags (lobes on left and right, and over the driveshaft), the fuel is pumped between the two sections as well as to the engine. There are two fuel units that were replaced, and everything is working fine now. I believe that the TSB shows accessing the top of the fuel tank from a panel under the back seat.
 

·
Premium Member
Joined
·
1,376 Posts
This is happening to me now -

I got in the car today after putting in $10 (just to get me to Costco so I can get cheaper gas) and the needle was pegged on Empty and the lil red light was on. The "Miles to empty" 123.

So I get to Costco - filled it up and it only took 13 gallons. JohnMax did the new part fix your problem??
 

·
Premium Member
Joined
·
10,642 Posts
Discussion Starter #10
Yup the fuel sender fixed it. Its been over a year and all good.
 

·
Registered
Joined
·
71 Posts
johnmax said:
Yup the fuel sender fixed it. Its been over a year and all good.
Did you have one or two fuel sending units replaced?

I just had one replaced recently and I'm still having problems. I drove 17 miles and it was at 3/4 tank and when I went to fill up it went to 7/8 tank with 1.6 gallons. The dealership said it could be the sending unit from the other side of the tank.
 

·
Premium Member
Joined
·
10,642 Posts
Discussion Starter #12
They only replaced one i think. Cant find the sheet to see which one :? .
 

·
Registered
Joined
·
71 Posts
johnmax said:
They only replaced one i think. Cant find the sheet to see which one :? .
They only replaced one for me too, but they did the Main Sending Unit when the TSB says it could be the Sub Sending Unit. All was good for less than a day.

2 days ago I was at 110 miles with 1/2 tank, yesterday at 120 miles with an empty tank and today at 125 miles with 1/4 tank. That fuel gauge is moving around more than my speedometer. Whatever they did, it got worse.
 

·
Registered
Joined
·
31 Posts
Anakin674 said:
johnmax said:
They only replaced one i think. Cant find the sheet to see which one :? .
They only replaced one for me too, but they did the Main Sending Unit when the TSB says it could be the Sub Sending Unit. All was good for less than a day.

2 days ago I was at 110 miles with 1/2 tank, yesterday at 120 miles with an empty tank and today at 125 miles with 1/4 tank. That fuel gauge is moving around more than my speedometer. Whatever they did, it got worse.
They replaced one sensor about a year ago, and I started to have problems again last month. Yesterday they replaced the 2nd sensor and everything is working fine now.
 

·
Premium Member
Joined
·
1,376 Posts
So I'm goin home - with a quarter tank.......all of a sudden the gas needle drops and the lil red light comes on. "Miles to Empty" show ****. So I get off the freeway, fill it up ($55 - ouch) Then took some pics......the needle was all the way up as I left the gas station


This is 2.3 Miles after I left the gas station



This is 3.7 Miles after I left the gas station


This is getting too much for me - Im gonna see if I can take it in next week...... :x
 

·
Premium Member
Joined
·
1,376 Posts
I just dropped my FX off at the dealers & they will start to work on it tomorrow. One thing that he said was that they were gonna fill it up and then see what happens - then they will charge me for the gas....... :shock: They better not goto some outrageously priced station, I aint paying $4 a gallon.
 

·
Registered
Joined
·
102 Posts
I have the exact same problem with my 03. It drops really fast but after turning off the engine then starting it again, the needle goes to where it's supposed to. Anyone else have the same problem?
 

·
Premium Member
Joined
·
1,376 Posts
** UPDATE **

Service guy just called - they were able to duplicate the problem so they are replacing both senders for me. Covered by warranty. I'll post more when I get the car back.


**** UPDATE 5/18****

Got my car back - they replaced both fuel senders. I went to fill up afterwards and the needle was working fine. Now Im just waiting for my window trims.
 

·
Registered
Joined
·
71 Posts
Apparently, you have to walk the techs through the work they need to check or else it's likely they'll do the wrong thing. When I dropped my FX off, I told them about the TSB and that the Sub sending unit needed to be checked.

What did they do? They checked the Main sending unit, found a problem, replaced it and left it at that. They never bothered checking the Sub unit. Needless to say, the problem was not fixed. This time, I went back and firmly insisted that they look at the sub unit as I had requested previously. Surprise, surprise...the sub unit was faulty, they replaced it and everything's working fine now.

Now I just have to go back for the 4th time in 6 months for my VDC/Slip light issue. And again, last time I asked them to look at TSB issues and ideas from the forum: TPS, main wiring harness, voltage regulators and various sensors. And yet again, they ignored me and "found" other causes (ABS pressure sensor, knock sensor harness, ABS control unit); none of which fixed the problem.

It wouldn't be such a big deal for all this work if the dealership was nearby, but it's about a 3 hour round trip for me. It's been getting old and now it's downright annoying.
 
1 - 20 of 43 Posts
Top