Infiniti FX Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I need help. The ground cable pulled out of my aftermarket amp and touched another wire and shorted out my entire dash/gauge cluster and instrument panel lights! The navi screen and stereo are also off, and my A/C is stuck on full blast (the climate control buttons also do not work, but those lights are still on). Anyone know which fuse controls these items? I looked through all 3 fuse boxes, and the ones that were even close to what I was looking for were checked and all still good. Does anyone know what this fuse would be labeled as? I posted on iS and also read my entire owner's manual, but there are no specific fuse locations listed. Any help would be greatly appreciated. Thx!!
 

· Premium Member
Joined
·
10,004 Posts
What year FX?
 

· Registered
Joined
·
182 Posts
He's got a 2006 FX45.. As I mentioned in your other post, the same thing happened to me, same symptoms, when I was modding the media center and I shorted a fuse... I have a 2nd gen, but the fuse was in the driver's kick panel and I believe it was labeled radio/media or something close.
 

· Premium Member
Joined
·
10,511 Posts
How did you check them? Visual inspection or fuse tester? I had some electronic gremlins in my FX once and I ended up pulling EVERY fuse out (yes, even from the 3rd fuse box!) and tested each one with a multimeter before putting them back in... I worked my fuse puller so much with that one job, the hooks used to pull out the fuses were considerably worn afterwards... :p
 

· Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
I finally found the culprit after some helpful advice on iS. It was a 10A fuse in the passenger compartment kick panel marked "AUDIO MIRROR." I popped out the blown fuse (and it was clearly blown!) and slid in a new one and now I'm good as new. Kind of strange that a little 10A fuse controls that much stuff...
 

· Premium Member
Joined
·
10,004 Posts
Isnt that what PMG suggested above?
 

· Registered
Joined
·
1 Posts
I finally found the culprit after some helpful advice on iS. It was a 10A fuse in the passenger compartment kick panel marked "AUDIO MIRROR." I popped out the blown fuse (and it was clearly blown!) and slid in a new one and now I'm good as new. Kind of strange that a little 10A fuse controls that much stuff...
hey I got a 2009 fx35 My cluster gauges not workin properly I changed a fuse in my gas hand start working then it stop I check the fuse I put in it was blown that fast My ac control not work either
 
1 - 7 of 7 Posts
Top