Infiniti FX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I'm having a problem with my '04 FX45. When I turn the key off, and actually remove the key from the car and close all doors.. if I wait till the dome light fades out, the navigation screen will turn on! It prompts to hit "I agree" as if someone started the car! No doors open, no keys around the car... its sitting there turned OFF! And yet, the navigation turns on. Also, the radio will turn on.

What the heck is going on??? Anyone experience this?
 

·
Premium Member
Joined
·
1,469 Posts
Sorry, but this is the first I have heard of such a thing. I suggest taking the car into your dealer to get it looked at. Good luck.
 

·
Premium Member
Joined
·
368 Posts
I second the notion. Something is definitely amiss.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
OK.. the car has decided to act normal today. It is no longer turning the radio on by itself.

This car was owned by a lady who passed away.. I bought it with only 8,450 miles on it last month. It was parked in her garage for two years until her husband sold it.

Now I'm spooked. It was playing classical music all day yesterday.
 

·
Premium Member
Joined
·
1,469 Posts
Alright, its time to call in the Ghostbusters! :lol: :D :p
 

·
Premium Member
Joined
·
800 Posts

·
Registered
Joined
·
56 Posts
wierd, that samething happen to me couple weeks ago..thought i was the only one who experienced that...when i brought it in to get my alignment done and carbon blast...and for some reason they suggested me to get new battery because my car wouldnt start...which i think they burned me for $90!! it was either new battery or tow it home :evil: anyways..when i brought it back home i shut my car off and my nav wouldnt shut off, so i started back up and now my CHECK ENGINE light came on...right then i was really pissed and called back the dealer and only the salesman are available and all the techs are gone...but i demanded a rental and dropped it back off to have them look at it...the manager thought it was stranged...the next day the tech called me and couldnt duplicate it...from what the tech are saying that...maybe my capicitor from my amp is back drawing power to the nav?...well, i dont know? by anychance have you hooked up a system also?

*i thought it was when they installed the new battery, they mightve installed it unproperly and sparked something?..*
 

·
Registered
Joined
·
56 Posts
well it seem to happen to me again..but this time the radio doesnt turn on...but my nav stays on only...im scared they wont cover it under warranty, because of my aftermarket system... :?
 

·
Registered
Joined
·
21 Posts
Hello does anyone have the solution for this problem: NAV DISPLAY stays on while Contact is off and key is out.
No one else has replied since 2006 so i try to blow it some energy into it
Case
 
1 - 9 of 9 Posts
Top