Infiniti FX Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I need help with my 05 Fx35. I have no lights, radio, seat power etc but my battery is good. Does this sound like a bad fusible link at the battery? oh, No I cant jump it off because its not getting pwr from battery.

Thanks in advance
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
After troubleshooting this issue I found a bad fuse link on the fuse holder on the positive battery cabel. The fuse holder consisted of five fuse links: 120A, 60A, 80A, 80a, 100A.
The main 120A link had melted. Its in series with the battery. So, when it melted, no pwr was allowed to any of the vehicle systems. The other fuse link are parallel to 120A and positive battery terminal. The knew fuse holder assy cost 51.99 at
the Infiniti dealer.
My fx set for two plus days before I could look at it. When I got pwr restored, I had no issues with any system. I didn't half to reprogram anything.
I'm sure this was caused by bad connection on jump off. Yep, my son tried to give his buddy a jump and screwed up. I was more eager to figure issue than upset about it. Now I'm HAPPY, its yard work/grass cuting time. Let's just say he paid for the part and some, Lol.
Sometimes you just got to take the good from the bad.
 

·
Registered
Joined
·
2 Posts
I need help with my 05 Fx35. I have no lights, radio, seat power etc but my battery is good. Does this sound like a bad fusible link at the battery? oh, No I cant jump it off because its not getting pwr from battery.

Thanks in advance

Mines does the same thing, i tried 4 new fuses but they all keep blowing… idk what could be wtong
 
1 - 4 of 4 Posts
Top