Infiniti FX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
551 Posts
Discussion Starter #1
I have searched the forum and F/A and found nought on this noise.
Has ne1 ever had a knock coming from what would seem to be the front left area of the FX45 ?

My friend who has an 03 also has this knock. Mostly prevalent during turns...
Thanx
 

·
Registered
Joined
·
1,423 Posts
FX4U2C said:
I have searched the forum and F/A and found nought on this noise.
Has ne1 ever had a knock coming from what would seem to be the front left area of the FX45 ?

My friend who has an 03 also has this knock. Mostly prevalent during turns...
Thanx
i kinda have had the same occurance.....

it sounds like the shock is bottoming, or something.....

it happened when i went over a pretty big (unexpected) bump at speed.....

the dealer couldnt reproduce the problem....
 

·
Registered
Joined
·
551 Posts
Discussion Starter #4
I don't know.....but i still have it for sure !!!!
to me sounds like knock in strut/shock.......
 

·
Registered
Joined
·
3,159 Posts
FX4U2C said:
Has ne1 ever had a knock coming from what would seem to be the front left area of the FX45 ?

My friend who has an 03 also has this knock. Mostly prevalent during turns.
Sumbitch- was just gonna post on this. First time I heard it (and trust me, I've tossed my '45 around long before now) was Saturday when making a y'all-woulda-been-prouda-me 90-degree left turn onto a road going uphill at 35-odd MPH. I figured it was the VDC kicking in, so I didn't worry about it. Sure enough though, it happened again a little while later, and as I don't feel any steering or alignment differences, I wonder if something has managed to shake loose.
 

·
Registered
Joined
·
551 Posts
Discussion Starter #6
this is prevealent on 03 and 04's. FX45's

2 weeks after i got my 04 my friend who has 03 says " yip, they never fixed the knock yet"
 

·
Registered
Joined
·
1,944 Posts
i've been having more of a full front suspension issue on small bumps.... the sound resembles like the knock you guys have mentioned but it also sounds like i'm missing bushings or something on the sway bar or on the control arms. I've already replaced my tie rod end links for the steering rack, i figured that was the issue since i had crazy brake jutter at high speeds and when i lifted the front wheels off the ground i could wobble them side to side, but not up/down. Anyone else have this issue????
 

·
Registered
Joined
·
470 Posts
definetly not the shocks and struts because I have had it since I got it and I have lowered the fx on springs change the struts and now I have coil overs and it is still there but only when fully turned and going up a steep driveway so far havent figured anything out but I can almost live with it.
 
1 - 9 of 9 Posts
Top