Infiniti FX Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
411 Posts
Discussion Starter · #1 ·
And man is it L-O-U-D. Especially as the RPMs increase - very loud at 5K+. So loud that I'm actually considering putting the stock airbox back on.

Haven't had a chance to do some acceleration runs yet, so I can't say about extra power. But I reset my trip computer today and got over 22 MPG on the freeway on the way back from MSP Motorsports in Frederick...

BUT... I'm also getting some warning lights now. Slip, AWD, ABS, and VDC. Dunno if it's related to the fact that I just installed the Eibach springs and JWT Pop-Charger today or not... As a side note, the MSP guys weren't the most helpful in troubleshooting, and suggested that I "got to my dealer" to find out what the lights are about. So here I am, sitting at the dealer, waiting to hear about the warning lights. I'll keep everyone updated.

Matthew
 

·
Registered
Joined
·
309 Posts
Too Loud??? From what i have heard from my Stillen CAI the more the merry'er.. So, what about the lowered look and feel??
 

·
Registered
Joined
·
411 Posts
Discussion Starter · #3 ·
Love the look, feel, and handling of the FX with the Eibachs installed. Just waiting to get those warning lights cleared up before I beat on it too hard. With AWD/VDC/ABS warning lights, I'm not 100% confident in the vehicle's ability to stop as needed.

Matthew
 

·
Registered
Joined
·
411 Posts
Discussion Starter · #4 ·
I must bet getting old. This thing is really loud. I'm gonna give it a couple weeks, though.

Couple issues with it, maybe other members can help?

Seems to run very rich right now. Just letting the car sit and idle smells bad. I did reset the ECU, so I assume this will "learn" itself back to a better idle and/or air/fuel ratio? Do I need to let it sit and idle for a bit to speed up the learning process?

I hear a faint "psssst" sound at very slight throttle openings (5-10%?) and low RPMs (1000-2500?). Definitely goes away with bigger or smaller throttle openings and more RPMs. Sounds almost like a very quite wastegate. Does this sound like a leak? Has anyone else noticed this? If this is a leak, could this be causing the rich condition described above?

Ugh. I'm seriously considering going back to stock. The noise and all the other issues kinda have me regretting the JWT/Z-tube mod. But I will say that I got fantastic mileage on the trip home. And that's worth something with gas prices as high as they are.

Matthew
 

·
Premium Member
Joined
·
3,582 Posts
A friend of mine bought a G35 sedan after driving my car(lives in Miami).I got him the JWT and Z tube to pep it up.When i drove the car on vacation,it roared when I got into it,but otherwise normal.He is a very mild mannered Judge and he liked it as well???
 

·
Registered
Joined
·
443 Posts
It's normal for the "psssst" sound.
 

·
Registered
Joined
·
411 Posts
Discussion Starter · #9 ·
mhgsx said:
I'm willing to bet that one of your wheel speed sensors is either unplugged or fu-bar'd.
Exactly right. ShadyJC helped me diagnose the problem and sent me a PDF file on the subject. I guess the wheel sensors are a bit delicate. We popped the wheel off at the shop, and it was attached. Fiddled with the wire a bit - made sure all the fittings were snug, that there were no twists, and that the white strip faced out, just like the PDF said. Put the wheel back on and the warning lights were off. So happy to have that behind me.

liug said:
It's normal for the "psssst" sound.
That's a relief to hear. What's the source of the sound? Any old threads on it here? What's the source for this information? I'm learning to love the loudness, and if this sound is normal, I think I can live with the JWT setup. The gas mileage is noticeably better, and the power seems to be better, if only at high RPMs - 4k and higher.

Matthew
 

·
Registered
Joined
·
411 Posts
Discussion Starter · #10 ·
Figured I'd give an update... Getting used to the sound of the Pop-Charger. I'm starting to like the intake honk, but the PSSST sound at partial throttle openings is driving me nucking futs!

I know there are at least a few other members with Pop-Chargers... Does anyone else have this issue? Is it normal, or do I have some kind of a leak? liug - have any more information? If this is normal, what makes this sound? Any way to tone it down a bit?

I'm thinking that even if this sound *is* "normal", I may go back to the stock airbox. Probably stock airbox with K&N panel and z-tube. Just a thought.

Matthew
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top