Infiniti FX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
I thought I was getting ahead of a few issues when another one popped up. Intermittently, the FX50 will go into limp mode and not allow the engine to go above 3500 rpm. At first I thought it might be a transmission issue, but I once I got home, it was doing the same in neutral and park. It seems to be happening once the engine is fully warmed up, but not always. If I let the car fully cool, then the problem appears to go away for a while but will return randomly. I have no SES light and no pending codes. I think it may be a sensor issue, but I don't want to just start swapping parts in. I was thinking that I will just drive it and hope that a code pops up. Would the dealer equipment be able to identify a code even though I can't with my Blue Driver OBD reader?
 

·
Registered
Joined
·
65 Posts
Discussion Starter #2
I think I have the problem resolved. This whole issue initially started with the FX50 going into limp mode with a SES light and a P0014 code. I replaced the exhaust vvt solenoid and the problem went away. At least I thought. Although the code went away and I no longer had the SES light, I still had the limp mode problem when the engine was warmed up. I searched for the part number and ordered an aftermarket solenoid. I pulled the aftermarket solenoid that I had previously installed and found that the solenoid was exactly the same except that the mounting tab was directly across from the connector, while the original has the tab at the 10 O'clock position. I think that installing the aftermarket solenoid resulted in the oil passages being slightly off the required alignment, resulting in reduced oil pressure to the vvt gears at high load. I had to cut the mounting tab off so I could install the solenoid with the proper orientation. I fabbed a new tab with a hose clamp and a small piece of metal. I have gone on a few test drives over the past few days and all is back to normal.
 

·
Premium Member
Joined
·
1,726 Posts
Glad you got it sorted out Denis. Out of curiosity, what was the price difference between aftermarket and oem for the part? Or could you even get it oem?
 

·
Registered
Joined
·
65 Posts
Discussion Starter #4
The dealer here in Halifax wanted $459 Cdn. Aftermarket was $35.
 

·
Premium Member
Joined
·
1,726 Posts
I see. That is one **** of a difference.
 
1 - 5 of 5 Posts
Top