Infiniti FX Forum banner
1 - 4 of 4 Posts

Registered
Joined
1 Posts
Discussion Starter · #1 ·
-The car makes some creaking/ticking noises only when I move the steering to make a turn. It isn't related to the cv joints/axel since it isn't constant.

-There's a clunking sound from the rear differential (it has a lot of noticable play when shifting gears from p to r or d - sometimes shifting to d from p doesn't make any sound when the car has been running for some time).

-There's a mild but noticeable thud sound from the rear diff area when I slowly brake to come to a stop.

-When I first start the car and shift from P to D to pull out of the parking. The moment it shifts to D, there's a loud thud from the rear differential. This is a long time problem but now there's another thud from the gear shifter area itself. The sound can be felt in the gear shifter too.

When the car is running/warmed and I start it up even after a few hrs the shifter thud does not happen again. Any idea what this could be?

-New OEM brakes/rotors still make that annoying squealing sound at low speed braking in drive and especially in reverse.

Apart from that every other aspect of the car is perfect. It's super quick, has smooth acceleration, shifting, turning etc.
 

Registered
Joined
9 Posts
-The car makes some creaking/ticking noises only when I move the steering to make a turn. It isn't related to the cv joints/axel since it isn't constant. -There's a clunking sound from the rear differential (it has a lot of noticable play when shifting gears from p to r or d - sometimes shifting to d from p doesn't make any sound when the car has been running for some time). -There's a mild but noticeable thud sound from the rear diff area when I slowly brake to come to a stop. -When I first start the car and shift from P to D to pull out of the parking. The moment it shifts to D, there's a loud thud from the rear differential. This is a long time problem but now there's another thud from the gear shifter area itself. The sound can be felt in the gear shifter too. When the car is running/warmed and I start it up even after a few hrs the shifter thud does not happen again. Any idea what this could be? -New OEM brakes/rotors still make that annoying squealing sound at low speed braking in drive and especially in reverse. Apart from that every other aspect of the car is perfect. It's super quick, has smooth acceleration, shifting, turning etc.
Are you a member of FX/QX Facebook page. There people that possibly can help you.馃
 

Registered
Joined
1 Posts
There's a clunking sound from the rear differential (it has a lot of noticable play when shifting gears from p to r or d - sometimes shifting to d from p doesn't make any sound when the car has been running for some time).

-There's a mild but noticeable thud sound from the rear diff area when I slowly brake to come to a stop.

-When I first start the car and shift from P to D to pull out of the parking. The moment it shifts to D, there's a loud thud from the rear differential. This is a long time problem but now there's another thud from the gear shifter area itself. The sound can be felt in the gear shifter too.

When the car is running/warmed and I start it up even after a few hrs the shifter thud does not happen again. Any idea what this could be?
All of this points to the infamous fx50 "axle click", mine has been doing this for the past 50k+ miles and hasnt gotten any better or worse. Several others with fx50 report the exact same, the solution is either buying new rear axles or you can try degreasing them, which works for some and not for others. I personally havent tried it yet. I wouldnt overthink it

as for your brake squeel, did you grease the caliper hardware? I only buy brembo pads, but I believe the OEM come with the low pad metal squeel thing, I always bend that back a bit more - sometimes during shipping or install they get banged out of spec and pushed forward too much, making contact with the rotor
 

Attachments

Registered
Joined
33 Posts
Your "thud" when you start it from cold check what the steady RPMs show on your tach. It could be that your cold start is holding the revs too high. It could be many possible things- how many miles- has the trans ever had a service [fluid change and filter?]. There could be a TSB on these that I'm not aware of. That it makes no thud once warm makes me think it might be this and not a basic mechanical issue.

Brake squeal could also be from being too gentle on the brakes. I've got a big Lexus with the Brembos and it's common for owners to complain about brake squeal. Unfortunately most of those owners are cough-cough very gentle on their brakes and clueless about needing to take their car out and actually USE the brakes every so often.

Good luck and keep enjoying!
 
1 - 4 of 4 Posts
Top