Infiniti FX Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi there!

I'm sorry that my first tread here is crying for help and plese forgive me for my bad english. I'm from Bulgaria, it is a smal country in Europe on Black Sea and near Greece and Turkey. This summer I've bought 2004 Infiniti fx35. It was imported hear in 2008 from USA, New York. The car is in very good condition, 78 000 miles. The last owner was a woman and she had drove the car very rarely, most of the time here the car stays in garage. I have no any serious problems except this one, the problem with my radio..... It starts in the last month, it's was early morning when I start the engine. I've seen that radio does not work, I've thought that it is switched off but when I've pushed an on button nothing was happened. There is nothing on the display no RDS, no sound, no any radio frequency, nothing. After that when I've drove I've seen that sometimes when I've shift from "P" to "D" or from "R" to "D" the "st." letters appear on radio display and sometimes they disappear. The same is happen when I push the TRIP and PREV buttons. Two days I have no sound from radio, after that the car stayed two days in underground parking and on the third day when I start the engine the radio simply starts to work until..... yesterday, the same problem was happened again no RDS, no frequency, no volume, no sound, no any letters on the radio display except the "st." like in the last time. Every thing other displays and works OK - AC, dual temperature, fan mode and everything is OK also on the big display - Trip 1 and 2, fuel economy, maintenance.
So does any body had the same problem and how can I fix it? There is a some pictures and thank you in advance!
 

Attachments

·
Premium Member
Joined
·
10,995 Posts
That is a WEIRD problem but from the look of your display, are you sure your FX isn't an 06-08? The "ST" I'm pretty sure stands for "STEREO" for when you get a stereo FM signal...

Other than that, I have no idea what's going on... If it was just the display, then the stereo would still play but you just wouldn't be able to tell what was playing...
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
That is a WEIRD problem but from the look of your display, are you sure your FX isn't an 06-08? The "ST" I'm pretty sure stands for "STEREO" for when you get a stereo FM signal...

Other than that, I have no idea what's going on... If it was just the display, then the stereo would still play but you just wouldn't be able to tell what was playing...
Thank you for you answer. Yes I'm sure my car was produced in the end of 2003 and it was sold by the dealer in 2004. It has navigation, rear DVD player, video display for rear passengers, 20' wheels. Yes the st. is a stereo when the signal is stereo. The display is OK it's shows the dual temperature, fan mode, AC, but nothing about the radio or CD/DVD, and all the radio buttons under the display does not work (1,2,3,4,5,6, Vol., FM/AM, CD/DVD, Mute.....) and no sound.....
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4 (Edited)
So I've just made a self diagnostic of the radio unit, by pressing "Mute" and turning the "Volume". See the pictures below there is what I have. As I understand there is no connection between DCU and audio unit, between audio unit and satellite and between DCU and IVCS, or shortly the connection is abnormal.
So where could be a problem, what I must to check? What is DCU and IVCS, what they mean
 

Attachments

·
Premium Member
Joined
·
10,995 Posts
That's weird... That would most likely just be the connectors at the back of the stereo... You'll probably want to take it apart and take a look there first... I wonder if some rodents got up in your car and started chewing on the wires...
 

·
Registered
Joined
·
3 Posts
I am having the same issue on my 2003 fx35. Lights on on the radio but no sound. Was working earlier today...something to do with the mute button.?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
While you pressing "mute II" button, turn the "volume" clockwise or counterclockwise for more than 30 clicks and than you will enter the selfdiagnostic mode. Tell us what you have.
Good luck.
 

·
Registered
Joined
·
3 Posts
While you pressing "mute II" button, turn the "volume" clockwise or counterclockwise for more than 30 clicks and than you will enter the selfdiagnostic mode. Tell us what you have.
Good luck.
I did as you said and when I get to the diagnostic page and look at radio it says NG. Also, I bought an after market for my 2005 and can’t swap it out because everything it interconnected. I disconnected everything and everything on my dash stopped working. Why can’t an after market radio be installed???? Please help!
 

·
Registered
Joined
·
1 Posts
So I've just made a self diagnostic of the radio unit, by pressing "Mute" and turning the "Volume". See the pictures below there is what I have. As I understand there is no connection between DCU and audio unit, between audio unit and satellite and between DCU and IVCS, or shortly the connection is abnormal.
So where could be a problem, what I must to check? What is DCU and IVCS, what they mean
Hi
I have a same problem with my fx35 2011 no sound comes out from The radio The off on button and the volume doesn’t work either ... Everything else work perfectly and after 15 - 20 min driving the radio start working. Dealer Ask around 700$ ...any one have a suggestion plz ???
Thank you.
 

·
Registered
Joined
·
1 Posts
So I've just made a self diagnostic of the radio unit, by pressing "Mute" and turning the "Volume". See the pictures below there is what I have. As I understand there is no connection between DCU and audio unit, between audio unit and satellite and between DCU and IVCS, or shortly the connection is abnormal.
So where could be a problem, what I must to check? What is DCU and IVCS, what they mean
Hi, have you been able to resolve this problem? I have exact same problem with my 2003 FX45.
 
1 - 10 of 10 Posts
Top