Infiniti FX Forum banner

21 - 29 of 29 Posts

·
Premium Member
Joined
·
10,995 Posts
Wonder if it's being cranky... Have you tried unplugging and plugging back in your ECU and going through those steps? You may have just not seated it properly...
 

·
Registered
Joined
·
6 Posts
My 2004 Infiniti FX35 cranks but wont start, it happened after I disconnected and reconnected the ECM and followed these steps: 1. Unplug the battery from the car 2. Let the car sit for fifteen (15) minutes unplugged. 3. Install the new ECU 4. Reconnect the battery 5. Turn the key to AUXILIARY (or RUN) position (ignition half way to where all the lights come on - at this point the "Check Engine" light needs to be ON... if it's on then the ECU is in working condition). 6. Let sit for another five (5) minutes 7. Turn off the car But at step 5 the "Check Engine" light does not come on but the radiator cooling fun comes on and stays on. the engine cranks but it does not start, and my OBD scanner cannot connect (The same scanner was able to connect before). Any ideas?
 

·
Registered
Joined
·
6 Posts
My 2004 Infiniti FX35 cranks but wont start, it happened while driving followed these steps: 1. Unplug the battery from the car 2. Let the car sit for fifteen (15) minutes unplugged. 3.Reconnect the battery 5. Turn the key to AUXILIARY (or RUN) position (ignition half way to where all the lights come on - at this point the "Check Engine" light does not come on but the radiator cooling fun comes on and stays on. the engine cranks but it does not start, and my OBD scanner cannot connect (The same scanner was able to connect before). Any ideas?
 

·
Premium Member
Joined
·
1,673 Posts
The only place you are going to find just the bezel is going to be the junkyard or maybe E-bay. Anybody else is probably going to want to sell you the whole head unit. You may be able to find a non-functioning head unit including the bezel for a reasonable amount.
 

·
Registered
Joined
·
1 Posts
My 2004 Infiniti FX35 cranks but wont start, it happened while driving followed these steps: 1. Unplug the battery from the car 2. Let the car sit for fifteen (15) minutes unplugged. 3.Reconnect the battery 5. Turn the key to AUXILIARY (or RUN) position (ignition half way to where all the lights come on - at this point the "Check Engine" light does not come on but the radiator cooling fun comes on and stays on. the engine cranks but it does not start, and my OBD scanner cannot connect (The same scanner was able to connect before). Any ideas?
Did you ever figure this out? I have an 06 FX35 with the exact same symptoms
 

·
Registered
Joined
·
2 Posts
I have a 2012 FX-35 with only 75,000 miles and just Monday while stopped at a light, engine cut-off. Thought it was Battery or worse case, the althernator. Nope, my **** engine seized! Towed to Infinity dealer. they drain oil and found metal chiops. Then took oil pan down and parts of a piston fell out. This vehilce has been serviced at the dealer since it was purchased. I feel like I got a lemon. Going to write Infinity ASAP, wish me luck.
 

·
Registered
Joined
·
23 Posts
My 2004 Infiniti FX35 cranks but wont start, it happened while driving followed these steps: 1. Unplug the battery from the car 2. Let the car sit for fifteen (15) minutes unplugged. 3.Reconnect the battery 5. Turn the key to AUXILIARY (or RUN) position (ignition half way to where all the lights come on - at this point the "Check Engine" light does not come on but the radiator cooling fun comes on and stays on. the engine cranks but it does not start, and my OBD scanner cannot connect (The same scanner was able to connect before). Any ideas?
Did you ever figure this out? I have an 06 FX35 with the exact same symptoms
Sounds like a bad ECU if the scanner cannot connect.
 

·
Registered
Joined
·
1 Posts
My 2004 Infiniti FX35 cranks but wont start, it happened after I disconnected and reconnected the ECM and followed these steps: 1. Unplug the battery from the car 2. Let the car sit for fifteen (15) minutes unplugged. 3. Install the new ECU 4. Reconnect the battery 5. Turn the key to AUXILIARY (or RUN) position (ignition half way to where all the lights come on - at this point the "Check Engine" light needs to be ON... if it's on then the ECU is in working condition). 6. Let sit for another five (5) minutes 7. Turn off the car But at step 5 the "Check Engine" light does not come on but the radiator cooling fun comes on and stays on. the engine cranks but it does not start, and my OBD scanner cannot connect (The same scanner was able to connect before). Any ideas?
Good day all,please am having this exact same issue. Please I need hel ASAP
 
21 - 29 of 29 Posts
Top