Infiniti FX Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
So, all day on friday my FX was at the dealer for a sunroof replacement. Picked the car up, went to dinner...and then the problem begins.

The car started, however a SOLID red KEY light and a SOLID red PARK light remained on the dash...So I pulled over, turned off the vehicle, and from that point on it would not turn on.

Whenever the ignition was turned "on" these lights appeared on the dash. When I would try to turn the car over, it would not start. It had enough power, cause everything remained on, the starter would click, but the car would not turn over.

Eventually after trying so many times, I believe that battery wore down cause the nav screen would flicker when I tried to start it.

Roadside assistance came, the car wouldnt jump, so now its waiting at the dealership to be looked at monday morning.

I was wondering if anyone knew what those two indicator lights of the KEY and the PARK meant when they were on solid?



PS. I also tried starting the car with the "mechanical" key in the fob and it still would not start. Also, I have a remote/start alarm combo on the vehicle as well.

Any input is appreciated.

Thanks!
 

·
Premium Member
Joined
·
10,642 Posts
ShadyJC said:
I think that's a security lock-out. Your key is not authorizing to the car so it is enabling the starter kill.
Yup when that red key flashes. Be prepared for them to blame the remote starter (even tho it is not the cause of the problem).
 

·
Registered
Joined
·
73 Posts
Discussion Starter #4
haha thanks...

So what is a good response when they try to blame the remote starter?

Cause all I know is my car worked fine until it was at the dealer that day, then that same night is when I had problems


Also, why wouldnt the mechanical key work either when I tried that?


Also, the red key wasnt flashing it was a solid red key and a solid red park/break light...Ive had that "flashing" red light before when I use the remote starter, then turn the ignition...however this time the car wouldnt not start no matter what and a solid light was on, not flashing.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #5
Ok. Dealership told me that a key code (security feature) disabled the fuel pump because it thought the car was trying to be stolen??

They told me they reprogrammed my I-KEY, and the car instantly started.

This guy tried blaming the cause of course on my remote start/alarm combo...I have been told that this is really not the cause of the problem however, I was wondering if anyone does know what causes this?
 

·
Registered
Joined
·
789 Posts
I can't speak on any of these issues. But, I am concerned that the mechanical key did not work.
Did you try placing the key fob outside the vehicle when you tried the mechanical key?? If not I suppose that may have had a preemptive affect.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #7
I mentioned to the service guy as too why my mechanical key didn't work. He said after so many failed attempts the computer locked the fuel pump for good...or until it had to be reset by a dealer

Also, how easy is it to swap a new key into the remote start bypass module...looks like I will need to put a new valet key in there ?
 

·
Premium Member
Joined
·
10,642 Posts
Sounds like BS to me. I have had nissans and infinitis that i have started numerous times without an unauthorized key. When you try to do that, the BCM will disable the fuel pump. There is no limit to the amount of times you can unsuccessfully try. You may need to wait a little while before you use a valid key.

Hopefully they programmed any other i-keys or valet keys you have at the same time or else those are no longer valid. I guess they didnt remove the key in the remote start interface to program that. :?
 

·
Registered
Joined
·
187 Posts
I had a similar situation but my radio preset stations were reset once I got my FX started. Actually all things memory related were reset. Was this a normal case? This happened twice this week. Is my battery the guilty one here?
 

·
Premium Member
Joined
·
10,995 Posts
If all memory settings were erased, your battery died or was disconnected.
 

·
Registered
Joined
·
187 Posts
This battery reset happened once again today and I have a "service engine soon" light on my dash now.
If the battery was the guilty one here, shouldn't it just die and not power anything. Everything works in my car
just like normal. I'll visit the service tomorrow but would still need some opinions.
 

·
Premium Member
Joined
·
10,995 Posts
Someone mentioned before that the negative terminal on their battery somehow was loose... go check yours and see if you can tighten it up a bit...
 

·
Premium Member
Joined
·
2,732 Posts
Re:

AGray34 said:
Ok. Dealership told me that a key code (security feature) disabled the fuel pump because it thought the car was trying to be stolen??

They told me they reprogrammed my I-KEY, and the car instantly started.

This guy tried blaming the cause of course on my remote start/alarm combo...I have been told that this is really not the cause of the problem however, I was wondering if anyone does know what causes this?
There was a notice being distributed at my Infiniti dealer a year ago notifying people that their iKey can and will be disabled if it was placed in close proximity (a couple of inches) to an active cell phone. It was recommended that the ikey be kept in a separate pocket from any cell phone to prevent this.

My ikey stopped working in my '06 once and I couldn't start my car (I do not have a remote start or aftermarket alarm). Fifteen minutes later it worked. The dealer replaced the transponder receiver just in case.
 

·
Registered
Joined
·
187 Posts
The problem still continues even though the battery is changed with a new one. Apparently is was not the battery. When this happens the mechanical key doesn't work and nothing electrical is powered, not even the interior dome lights. Can this be due to a sudden short circuit. I have LED Dtrls. Can they be the cause of this after 8-10 months of use?

I know that it is not the cell phone or the ikey because I got out ofa cafe and my phone was in my friend's bag and I switched to my second ikey when you guys brought it up here.
 

·
Premium Member
Joined
·
10,642 Posts
Check the ground locations under the hood for corrosion (batt ground, etc). I believe someone else had this issue.
 

·
Registered
Joined
·
187 Posts
my car absolutely has no power. even the dome lights don't work. the crank doesn't work. I cannot even shift the car to neutral so that it could
be towed with a regular flatbed tow truck here. A tow truck with crane had to come and pick my car up. At this point I don't know what to do.
I left my car at the service lot but still wonder WTF happened... :(
 

·
Premium Member
Joined
·
10,995 Posts
YIKES! Hope you can figure this out and get your baby back quickly... keep us informed of any updates!
 

·
Registered
Joined
·
187 Posts
to be honest I've not tried shift lock because I did not know what to do (just poke something in or do something else?)
What I don't understand is how can all the power in my car be shut down. Thete is no sign of life. We even tried jump starting after waiting for 4 hours thinking that my car went into "stolen mode". Apparently it is in no mode at all.
I'll keep everyone updated since this would be a very rare situation on any given day.
 
1 - 20 of 25 Posts
Top