Infiniti FX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Recently, the cruise control on my '06 FX35 will not engage. When I depress the button, I get a loud beep and the amber cruise light comes on . This is the adaptive cruise control system. I even tried to hold the button down for a few seconds to bypass the adaptive control but that does nothing. Anyone else experience this, and how did you fix it? Thank you.
 

·
Registered
Joined
·
2 Posts
Hey cynot,
Don't know if you are still having the problem, but I had the same issue. Through research, I discovered that there is a sensor (laser?) mounted under the front grill. It resembles a small black box. Mine was disconnected, either by accident or on purpose. I put the car up on ramps and took off the bottom cover for the engine compartment(10 mm bolts) and was able to access the sensor from underneath the car. (teaching my wife a couple of new 4 letter words in the process!) I plugged it in and took it for a test drive. The cruise operates as it is supposed to now. I am not sure about the adaptive cruise... the indicator light comes on when activated, but I have not tried it in traffic as of yet.
Hope this helps!
 

·
Registered
Joined
·
1 Posts
2006 fx35
My adaptive cruise also doesn't engage. If I hold the button down it will work in non adaptive mode. I have not been concerned about the adaptive cruise enough to look into it yet.
The check engine light came on a while back and then the amber light came on even when I held the cruise button and the amber slip light also stayed on. My mechanic diagnosed it and changed a faulty cam position sensor and now cruise works in non adaptive mode again. Who'd of thought they would be related issues?
 
1 - 3 of 3 Posts
Top