Infiniti FX Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
832 Posts
Discussion Starter #1
Does anyone ever had any problems with the fogs not operating?

I'm having some electrical issues with both fogs out and the front passenger turn signal will skip about 10 flashes and will then continue flashing normal for a while...then repeat.

I've contacted Infiniti Service regarding the fogs, but didn't realize the turn signal problem until later tonight.

This is the second problem with the fogs...the first was condensation/water in foglights. They replaced one, but not the other due to the cost & the other was working. I also realized that the original fog had 3M clear protection and the replacement doesn't. This is something I must address them about. Since the 3M installer will replace this piece, I'm going to see if they have something to protect the rear bumper.

I've also stated the following problems and hopefully I can get them resolved:

Front driver seat bubble and loose/shifting/rattle.
Front passenger seat wrinkles.
CD player skips when first turned on (will replace unit)
Sunroof squeals/grinds when sunroof is being tilted.
Window trim fading...trim color/shade not consistent.

I have an appointment on the 22nd.

I'm going to see if they will perform an alignment/balance & rotate the tires also.
 

·
Registered
Joined
·
3,948 Posts
Sounds like a bad relay or something. The hyper-flashing signal is typically an indicator that something is amiss.
 

·
Registered
Joined
·
832 Posts
Discussion Starter #3
I brought in my FX35 for service today and I feel [email protected]!

I advised the service rep Matthew that there was a total of 12 problems I was having regarding my FX and the end result was only 3 out 12 was addressed.

Here are the results:

01 Customer states when hazards are set, right front lamp doesn't always continuously flash, will stop then restart.
Unable to confirm complaint at this time.
(note: front directional bulbs aftermarket blue bulbs)

I don't understand why they couldn't check out the problem, due to the bulb is working properly. It has nothing to do with what type of bulb is there.

02 Customer states fog lamps inoperative
(left side recently replaced still needs 3M cover installed)
Factory fog lamp bulbs have been replaced with aftermarket blue bulbs-will need to install factory bulbs to test.

What kills me is that they are the ones that installed the aftermarket bulbs for me at the time of service when they replaced the damaged fog lamp! At that time, I also had aftermarket bulbs and there wasn't any problems then.

03 Customer states hearing metal on metal rotational clicking noise from right rear when traveling at lower speeds.
Confirmed complaint; rear axle nut loose causing condition. Re-torque rear axle nut complete. Tested. Noise gone.

1 out of 12.

04 Customer states left and right front seat bottom cushions are distorted, appear to be "bubbling"
Unable to confirm any abnormal condition with either right or left front seat cushions at this time, no problem found.

Looks as if bubbles and wrinkles is normal wear regarding their opinion... :evil:

05 Customer states moonroof creeks when opening and closing.
Moonroof operational noises normal.
Lubricated sunroof gasket as requested by customer.

I had to demand this!

06 Customer states trim around some of the windows is discoloring, seems to be taking on a blueish color.
Unable to confirm any abnormal conditions with any of the window trims at this time, no problem found.

Right! I guess my trim is 3 shades of black!

07 Customer states DVD player intermittently skips when playing DVD's, will skip or flutter.
No DVD inside vehicle or in shop to test system at this time.

Give me a break! They couldn't find a dvd to test? BS! :evil:

08 Customer states left front seat assy has excessive play when shifting in seat or when accelerating.
Confirmed complaint; diagnose excessive LF seat lifter play. Replaced LF lifter assy completed. Tested. OK.

2 out of 12

09 Customer states vehicle pulls to the right when traveling at all speeds.
Unable to confirm condition at this time. Vehicle tracking straight w/tested, following crown of road, no problem found.

This is why my steering wheel is of to the left when I'm driving straight...hmmm! :?

10 Customer states CD player is skipping continuously when 1st started cold. Will skip for app 1st half hour of playing -SOP
Confirmed complaint; diagnosed internal CD player failure.
Replaced CD changer\audio unit completed. Tested operation. OK.

3 out of 12

11 Customer states hearing plastic creek\rattle noise from center console when traveling at all speeds - see S&R form.
Unable to confirm complaint. No problem found.

What is the S&R form? Still vibrating to me.

And finally:

12 Customer states brakes intermittently squeal with each application, seems to occur more frequently in humid weather.
Unable to confirm any abnormal brake noises at this time.
All brakes OK at this time. No problem found.

This wasn't a big deal, it screeches only once in a while.


I would like to get some opinions regarding my service. So far, I have not had a pleasant service experience from Infiniti. I had better service performed by my Honda dealer!

My previous vehicle was a Lexus and Infiniti will never come close.

I was so pee'd off, I was even considering getting rid of my FX and get the RX400 when it is released. Just due to the rotten service I've received so far.

What really sucks, is that the dealership is over 20 miles away and is considered the best in my state. I have another Infiniti dealer just 5 min from my house. but had bad experience there in the past...just ask Ak1nza.

What should I do to get these problems resolved?

Any help will be appreciated. :)

Sorry for such a long post...I needed to vent 8)
 

·
Registered
Joined
·
599 Posts
I can concur with infx35. Infinti service around Boston is [email protected] Get this, I brought my car in for my 3750 service interval as well as to fix a list of problems. THEY DIDN'T EVEN CHANGE MY ENGINE OIL....

I brought my car in for several problems and only a few got fixed, with the rest resulting in the same answers:

-unable to reproduce sound/problem
-no problem found
-customer is a nagging [email protected] and we are lazy to help him

well ok fine, not the last one but still. With the amount of money we spend on this car (and ****, I bought my car, not financed, not leased, BOUGHT), I do have expectations when it comes to service and the dealer I purchased from and the dealers here in Boston just don't live up to it.

Worst is that I recommended the FX to a friend who purchased it and he's not happy with the service either and it'll be his last Infiniti he'll ever buy.

Seriously though. I don't see what the big deal is. Dealers get paid for warranty work. The only reason I can think of that they will give excuses to not do the work is laziness. I don't see the point, I mean the technicians get paid by the hour and the customer wants their car fixed 100%. IF they keep the car an extra day or two but it comes back with all the problems solved it's MUCH more satisfactory than them trying to get you in and out quickly.....

sigh. Maybe I'm expecting too much.

I gotta go for servicing again too, but I'll probably hold off a while. Don't feel like dealing with it right now.
 

·
Registered
Joined
·
832 Posts
Discussion Starter #5
No responses regarding what I should do?

I think these problems should have been addressed and resolved from Infiniti without question. :evil:
 

·
Registered
Joined
·
832 Posts
Discussion Starter #6
Well, if anyone wants to know, I sent an email to Consumers Affairs and received this response:

Thank you for contacting Infiniti/Nissan North America, Inc. and allowing us the opportunity to be of assistance.

I have called the dealer and spoke with the service person Mr. Duby who advised me that he has look at your vehicle along the service advisor Matt and that they cannot duplicate the problems that you say you are having with your vehicle. If you are still having the problems you stated with your vehicle, you might want to take it to another Infiniti dealer for a second opinion.

If you have any further comments or concerns, please feel free to e-mail us again or contact our Consumer Affairs department at 1-800-662-6200.

Sincerely,

Precious G.
National Consumer Affairs


I was ripped s#it! What type of response is this? Telling me to go to another Infiniti dealer instead of dealing with the service I received from my dealer.

I found a couple of deep scratches on the bottom of my driver side armrest...must of happened when they fixed the assy for the excessive play to the seat. There are also scratches on my dash above the NAV screen when they replaced the CD unit. This was all included in my email.

I ended up calling them today and spoke to Fred.

This call was no better. I was advised to speak with Mr. Duby at my dealership and to explain my problems...they already know my problems and were not going to do anything about them. I was told that Infiniti can not tell dealers what the can do or not do...in other words "run their business" :shock:

What is Consumer Affairs Dept. for?

Looks like I'm back to the drawing board. :evil:

Thanks for dealing with my rant! :(
 

·
Registered
Joined
·
662 Posts
I think in general Infiniti dealers can't come close to Lexus, BMW or MB's in terms of the service quality. I go to my dealer not becaus I want to but because there is no other Infiniti dealer for another 30min drive.

Dealers don't care about consumer affair and as a matter of fact, they do get that kind of phone calls all the time.
 

·
Registered
Joined
·
832 Posts
Discussion Starter #9
particlefx said:
Sincerely,

Precious G.
National Consumer Affairs
Is that real? How about Precious FX? Or Precious M45? :roll:
YES! This is real!
She sounds like a dawg to me! :lol:

Now can anyone advise me what I should do in this situation? :?
 

·
Registered
Joined
·
46 Posts
infx35 said:
particlefx said:
Sincerely,

Precious G.
National Consumer Affairs
Is that real? How about Precious FX? Or Precious M45? :roll:
YES! This is real!
She sounds like a dawg to me! :lol:

Now can anyone advise me what I should do in this situation? :?
Better business bureau.. http://complaints.bbb.org/Welcome.asp

Also, is this your window trim problem:

http://www.infinitihelp.com/Ownership/B ... 03-057.htm

I am experiencing the exact same thing but haven't been to the dealer for it, yet...
 

·
Registered
Joined
·
292 Posts
01 Customer states when hazards are set, right front lamp doesn't always continuously flash, will stop then restart.
Unable to confirm complaint at this time.
(note: front directional bulbs aftermarket blue bulbs)
Dealing with dealerships is just plain not fun. Don't get me started on what happends when you have to go in for service at a Pontiac dealership :roll:

Anyway, with regards to your lighting/electrial issues, maybe swap back to stock lights and take it back in. I hate it when dealerships use a copout to not fix something but removing that excuse may help you help them find the true problem. Just a though...
 

·
Premium Member
Joined
·
1,036 Posts
Did you ever get your fogs working again? Mine just went out for no reason. I installed the 10ks last night and everything looked good, but today my fogs won't turn on now..........

Since both went out at the same time, I am assuming they ddin't die or anything.

What can I do to get them working again?

THANKS!
 

·
Premium Member
Joined
·
2,122 Posts
contaygious said:
Did you ever get your fogs working again? Mine just went out for no reason. I installed the 10ks last night and everything looked good, but today my fogs won't turn on now..........

Since both went out at the same time, I am assuming they ddin't die or anything.

What can I do to get them working again?

THANKS!
Did you change your fogs to HID also?? Since both your fogs went out it might be the Fuse, and the fuse box is behind the battery. When I changed my fogs to HID, the fuse blew out a few times.

Jim
 

·
Premium Member
Joined
·
1,036 Posts
I didn't change me to HID I just put in new bulbs. I'll check the fuse though. is there anything else connected to the same thing? LIke the horn or something so I can check?

THanks!

sorry, what do I do exactly if the fuse blew? :oops:
 

·
Premium Member
Joined
·
2,122 Posts
Nope the fogs have its own seperate fuse.

Jim
 

·
Premium Member
Joined
·
1,036 Posts
so which fuse in this picture is for the fog lights?


According to the service manual the fogs are 50Am, I'm :?

I have a 15A spare and a 10A spare from the driverside panel, so anyone know which one to use where?
 

·
Premium Member
Joined
·
1,036 Posts
must posted this pic a while ago I was just using it again for reference. not sure if i'm missing one, maybe because he was replacing one for the leds earlier.
 

·
Premium Member
Joined
·
1,036 Posts
OK I figured out it was the 15A one and it wasn't blown. I replaced it anyway with the spare and my fogs still don't work.

I'm pretty sure it's not the bulbs because they both went out the day after I installed my 10ks and they worked for a week previous to that.

What should I do now?

Appreciate your help!

TAY
 

·
Registered
Joined
·
4,053 Posts
Put the old ones back... that will quickly tell you if it has to do with the bulbs or the system feeding the bulbs.

Didn't someone else have this exact same problem a while back?
 
1 - 20 of 22 Posts
Top