Infiniti FX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Was messing around with led DTRL last night and I've seemed to pop a fuse or relay somewhere. Now the DTRL don't work with regular 7443 bulbs in, nor does the interior lights on the radio/HVAC on the center console. NAV does not auto dim when auto headlights turn on either.

I checked all the fuses today and they were all good. I'm guessing I might have pop the relay, but I can't get it off to check. I guess I need to grab a new relay anyways to really check it?

Any insight would be helpful.
 

·
Premium Member
Joined
·
10,645 Posts
cambo said:
I checked all the fuses today and they were all good. I'm guessing I might have pop the relay, but I can't get it off to check. I guess I need to grab a new relay anyways to really check it?
You didnt check the 3rd fusebox which is behind the battery. You'll need to pull off the cover to access it. It is in there.
 

·
Registered
Joined
·
24 Posts
I had the same problem 2 weeks ago. You have to take off the battery housing and lift the windshield cover and there is a hidden fuse box back there behind the battery. I thought it was a relay too until I read the forum and someone told me about the hidden fuse box. It should be a 10A fuse for the DTRL that is out.
 

·
Registered
Joined
·
2 Posts
I had the same problem 2 weeks ago. You have to take off the battery housing and lift the windshield cover and there is a hidden fuse box back there behind the battery. I thought it was a relay too until I read the forum and someone told me about the hidden fuse box. It should be a 10A fuse for the DTRL that is out.
 
1 - 5 of 5 Posts
Top