Infiniti FX Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
302 Posts
Discussion Starter #1
Hello,

Is anyone getting this message when they start the car and click ok on the NAV. I was getting it once ina while but it is starting to get worse and worse. Kind of frustrating as you can't use the nav etc. Please let me know if anyone has contacted the dealer about this.

Thanks
 

·
Registered
Joined
·
176 Posts
My DVD NAV stopped working on my very first trip in a brand new 2003 FX35. The unit was replaced and everything worked fine. Now I have a 2004 FX35 also with tech package, and last week I got "disc error". I ejected and reinserted the disc and it worked fine. Hopefully it was just a speed bump or something that set it off.
 

·
Registered
Joined
·
185 Posts
Mine started with this problem the second week we owned it. Been waiting for 2 1/2 weeks now for a new unit for under the seat.

It seems to be a fairly common problem from what I have read. Since it's going to be replaced anyway, I just give it a good, and I mean good hit and it jars the tracking head loose and it works for a few more days.
 

·
Registered
Joined
·
3,159 Posts
4tyson said:
is there anyway to tell what version you have without taking the disc out?
Nope.
 

·
Registered
Joined
·
662 Posts
This problem has been quite common and I had mine replaced also about a month ago. Dealer told me that reader got stuck frequently and it was causing the error sign. Don't bother trying to fix it. It got worse and finally stopped working.
 

·
Premium Member
Joined
·
2,609 Posts
The player is under the front passenger seat. Access it from the rear seat by first moving the passenger seat forward and then removing the plastic/rubber cover from the DVD player. You will see an eject button -- push it and the disc will eject itself.
 

·
Registered
Joined
·
302 Posts
Discussion Starter #9
went in today and they replaces the nav player under warranty. I saw the bill that they submitted to the dealer. $3600.oo CDN for the nav player. That is just crazy. Glad I wasn't paying.
 

·
Registered
Joined
·
97 Posts
I know this is an old topic...did you guys have to take in your car to show them the problem and then take it in again when they get the new navigation unit in? I'm a little far away from the dealership and I was curious if they could order the part without seeing the car.
 

·
Registered
Joined
·
185 Posts
Kodiak33 said:
I know this is an old topic...did you guys have to take in your car to show them the problem and then take it in again when they get the new navigation unit in? I'm a little far away from the dealership and I was curious if they could order the part without seeing the car.
I would think that since the error was common enough that they would work with you on this. Part of it will be based on how good of a relationship you have with your dealer.
 

·
Registered
Joined
·
97 Posts
Thanks for the reply. I've never actually been to a dealer yet, I bought the car used last Thanksgiving and I've done maintenance on it (oil change etc). I'll probably have to let them look at it since I have not been to them yet.
 

·
Registered
Joined
·
97 Posts
Well got the car back with a new unit. Apparently there is a TSB for it, so if you have one (TSB 04-042) you might want to get it fixed before it craps out.
 
1 - 13 of 13 Posts
Top