Infiniti FX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hotel parking valet left seat heating ON which drained the battery. Then they tried to jump start the car and crossed the cables. It blown the main fuse on the positive battery contact (120A, costs $60) and another fuse marked as radio. After I replaced these 2 fuses, everything works fine except that there is no sound at all from audio system. Navigation screen works, shows stations or disks but no sound. I suspect that it can be another fuse. Is there audio amp fuse in FX? Thanks. (I spent almost 6 hours yesterday cleaning this mess. What a pain.)
 

·
Premium Member
Joined
·
10,645 Posts
20 amp fuse #17 in the drivers kick fuse panel for the main amp, and 15 amp #32 under the hood by the battery for the sub amp.
 

·
Registered
Joined
·
1 Posts
Hotel parking valet left seat heating ON which drained the battery. Then they tried to jump start the car and crossed the cables. It blown the main fuse on the positive battery contact (120A, costs $60) and another fuse marked as radio. After I replaced these 2 fuses, everything works fine except that there is no sound at all from audio system. Navigation screen works, shows stations or disks but no sound. I suspect that it can be another fuse. Is there audio amp fuse in FX? Thanks. (I spent almost 6 hours yesterday cleaning this mess. What a pain.)
I have exactly the same issue and cause! Please can you tell me exactly what fuses you changed and where are they located
 
1 - 3 of 3 Posts
Top