Infiniti FX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
Hello All
Its been a minute since Ive been on here but my 2011 FX50S is starting to show signs of an issue. What used to take only holding in the gas pedal and hitting the push start to start, now i have to basically leg press the gas pedal to get it to start. Im guessing theres some kind of switch or something that has to be engaged to get it to start in the gas pedal or something. I shouldnt have to stomp on the gas pedal to make the connection. then when it does start it sounds like its struggling to turn over.

Does anyone know what could be causing this?? And what the fix\cost is??
Is this something a DIY can do??

Thanks
 

·
Registered
Joined
·
89 Posts
You shouldn't be touching the gas pedal at all when starting the car. You should be pressing the brake pedal. Is the check engine light on at all. see if you can pull the codes to determine if there are any pending. Often times, a bad crank position sensor will cause intermittent starting issues.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #3
Sorry correction. I mean the BRAKE pedal. It kinda sounds like a weak battery as well but is more related to the brake pedal as far as I can tell.

Thx
 

·
Registered
Joined
·
89 Posts
Have someone watch the brake lights as you slowly push on the brake pedal. If the brake light comes on, then the switch is fine and you don't need to press any harder. You say that it sounds like a weak battery. Do you mean that when you press the brake and push the start button, the engine turns over but doesn't start? If the engine does crank (makes the RRR, RRR, sound) then it has nothing to do with how hard you are pressing the brake. If it isn't cranking as quickly as it used to, then it could be a battery issue.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #5
Have someone watch the brake lights as you slowly push on the brake pedal. If the brake light comes on, then the switch is fine and you don't need to press any harder. You say that it sounds like a weak battery. Do you mean that when you press the brake and push the start button, the engine turns over but doesn't start? If the engine does crank (makes the RRR, RRR, sound) then it has nothing to do with how hard you are pressing the brake. If it isn't cranking as quickly as it used to, then it could be a battery issue.

Ok Thanks Ill take it to an autoazone or something and have them checkout the battery. Any suggestions on a GOOD strong battery for the FX50?? I currently have an interstate battery in there which i thought was a good battery.

Thx
 

·
Registered
Joined
·
89 Posts
I am not suggesting that you have a bad battery. If the engine isn't cranking strongly, it could be several things. Have you been primarily short trips where the battery isn't getting properly charged. You may have an issue with the alternator, or something else in the charging circuit. Or, it could actually be a bad battery. As for which battery to get, I suggest asking the auto store you go to. Get one with the most cranking amps that will fit.
 
1 - 6 of 6 Posts
Top