Infiniti FX Forum banner

161 - 169 of 169 Posts

·
Registered
Joined
·
13 Posts
jaguar2010 said:
I've had it with Infiniti today. Every time i go to complain about the jerks on downshift, they apply this useless TSB, which reduces jerks for a few weeks only. I told them to day to not apply this TSB and make sure they fix it. I am going to make a fuss if they still have the same answer.

I've been monitoring this post for a while. I ended up getting a 2010 EX35 that has the 5 speed transmission. 2011 was to get the 7 speed. After reading these posts and others, I decided not to take a chance on it, The 2010 EX35 does not have any of the annoying shifts. I drove the FX35 before I even read any posts about the new 7 speed and after driving it I did not like how it shifted. That's when I started to look on the internet to see if there were any comments on it. I found this post and others as well.

Does anyone know if they fixed it with the newer cars? I would guess it actually needs a mechanical change because a software change does not appear to fix it. I'm looking for a new car and would like to consider an Infiniti but if the 7 speed has the same problems I would drop it. It looks like most of the new Infinitis use this 7 speed.
 

·
Premium Member
Joined
·
10,995 Posts
rainman50 said:
I'm looking for a new car and would like to consider an Infiniti but if the 7 speed has the same problems I would drop it. It looks like most of the new Infinitis use this 7 speed.
The new JX has the CVT that the NISSANs have... different than the 7-speed but better? I'm not sold on CVT's on performance cars... and a FWD biased CVT car in the INFINIT lineup just sounds like a suped up NISSAN to me...
 

·
Registered
Joined
·
106 Posts
My wife has the 2012 EX and it shifts flawlessly. I have the 2012 FX50 and it does shift better than my 09 Fx35 but I attribute that to the more powerful engine driving the gears. I had the 09 reflashed and it did improve tranny performance, but every now and then it seemed to hunt for the right gear--not a big deal, but I did notice it.
 

·
Registered
Joined
·
31 Posts
I have a 2010 fx35. While in D mode when I am in drive but I brake at any time (for example at a stop sign) I find the transmission sometimes bucking. The vehicle doesn't move but you can feel it reving up or wanting to go. This is in normal drive mode and not sport. Does anyone else experience this? Is it normal for this tranny? Cause?
 

·
Premium Member
Joined
·
468 Posts
I think what you're experiencing is the normal engine braking which occurs when in downshift mode. Could be wrong but I believe it's designed that way.
 

·
Premium Member
Joined
·
468 Posts
Nothing to be sorry about. In fact, if I gave you wrong info it should be me saying sorry. In actual fact, I think the term they use to describe what you experienced as 'automatic rev matching' designed to rev the engine abit as it downshifts. In the "old" days of manual trannies, wwe used to do the same thing, rev the engine a bit before down shifting. :D
 

·
Registered
Joined
·
31 Posts
boomerkid said:
Nothing to be sorry about. In fact, if I gave you wrong info it should be me saying sorry. In actual fact, I think the term they use to describe what you experienced as 'automatic rev matching' designed to rev the engine abit as it downshifts. In the "old" days of manual trannies, wwe used to do the same thing, rev the engine a bit before down shifting. :D
Thanks for the info. I love the vehicle and am glad this is normal.
 

·
Registered
Joined
·
2 Posts
I have the same problem with my 2009 fx35 84000 km. And it is having this early upshifting issue already 5,6 years.I have gone for diagnosis.but no maintenance showed in transmission.i have told to official infiniti service in my country. They said that they have to take off the transmission and then they will definite the problem. But i know that its some programming issue, not mechanical.i drive in manual mode (tiptronic) everytime for that early upshifting. I have a question does it repeat this when the A/C is on? In my car ot shifts gear ideally when A/C is on. That shows this is a programming fail. I still look for solutions.if anybody know the solution please tell me

Sent from my MI 8 using Tapatalk
 
161 - 169 of 169 Posts
Top