Infiniti FX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi, I have had my FX 45 for about 6 months now and even though the specs shows the fuel tank is 90L, the most fuel that I have ever put in is 65L and that is after the fuel light has been on for 1/2 an hour of highway driving. Is this normal? is it just the design of the tank or position of the sensor? I never intend to run it to the last 10 L to stay away from the "dirty gas" level but I would like a little more confidence that I know how far I can go on a tank of gas.

Please let me know if anyone else has a similar situation.
Thanks, Gregg
 

·
Premium Member
Joined
·
1,760 Posts
Infiniti has had a few problems with gas level indicators. Usually the fix is to replace both fuel sender units. Not worth it if yours is reading even the way you describe in my opinion.
 

·
Registered
Joined
·
10 Posts
My issue generated P0463 code. The fuel sending units needed to be replaced. Was fine on full tank once it got to half tank needle would drop to E trigger the light then as I drove on the highway would gradually climb back up.

Sent from my XT1254 using Tapatalk
 

·
Registered
Joined
·
4 Posts
Hi, I have had my FX 45 for about 6 months now and even though the specs shows the fuel tank is 90L, the most fuel that I have ever put in is 65L and that is after the fuel light has been on for 1/2 an hour of highway driving. Is this normal? is it just the design of the tank or position of the sensor? I never intend to run it to the last 10 L to stay away from the "dirty gas" level but I would like a little more confidence that I know how far I can go on a tank of gas.

Please let me know if anyone else has a similar situation.
Thanks, Gregg
What gas stations do you go? I used to go religiously to either gulf or sunoco, thinking they had good gas. My fuel gauge used to do the same thing. After learning that they were not good, I started using BP, Shell, and Mobil 93 only. (Here in the states) Guess what, my gauge has never been more accurate.

Sent from my SM-G892A using Tapatalk
 

·
Registered
Joined
·
4 Posts
My issue generated P0463 code. The fuel sending units needed to be replaced. Was fine on full tank once it got to half tank needle would drop to E trigger the light then as I drove on the highway would gradually climb back up.

Sent from my XT1254 using Tapatalk
Mine did this too, until I changed the type of gas I used.

Sent from my SM-G892A using Tapatalk
 

·
Registered
Joined
·
10 Posts
I only use 93 octane from Exxon or BP. Back in the day when I had my 02 Q45 I put in some Royal Farm gas and the car would shake like it had mad cow disease.

Sent from my XT1254 using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
What gas stations do you go? I used to go religiously to either gulf or sunoco, thinking they had good gas. My fuel gauge used to do the same thing. After learning that they were not good, I started using BP, Shell, and Mobil 93 only. (Here in the states) Guess what, my gauge has never been more accurate.

Sent from my SM-G892A using Tapatalk
I have been using 91 octane from Costco, every couple months I run a tank of 93 with a bottle of injector cleaner.
 
1 - 7 of 7 Posts
Top