Infiniti FX Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Good morning,

I hope someone might save me a tow to a mechanic. 2005 FX45 with 42,000 miles. Owned for two years, never any problems, until now...

Starter cranks, but engine doesn't start. Put new air filter in just to be safe (old one was pretty dirty). I'm pretty sure I hear the fuel pump when I first turn the key. Original battery which I will replace, but I have a good charger hooked up.

I turn the key and it cranks strong but no start. Any ideas?
Thank you,
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Someone just suggested the crank position sensor?

I had that part go bad on my MB CLK. On the benz it was intermittently hard to start. The FX is not wiling to start. Crank sensor is cheap and easy to install so I'll probably try it...
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Power seats, radio, all good.

My mechanic friend who suggested the crank position sensor said it may be that, if when I crank the tachometer needle doesn't move, which it doesn't. Should have the part Wednesday night; will write back after I put it on.
 

·
Registered
Joined
·
28 Posts
Im having this problem right now. Car is sitting on jumper cable hooked to my other car but it wont start and starter is clicking strong. My question is how to replace to the crank positioning sensor?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
mikesd1980 - I'd like to clarify that the bad crank position sensor symptoms are that the start motor is cranking strong and turning the engine but no spark. When you say clicking, it makes me think the starter might not be cranking, do you hear the usuall rrr,rrr,,rrr,rrr, like you would on an older car if you unplugged the coil wire.

If your engine behaves as though there is no spark, then the crank sensor is likely the culprit.
It's located on the bottom of the engine, at the back, passenger side near the middle, where the transmission attaches to the engine.

It is held on to the engine with one small bolt, and has a long three wire harness running to it. The only tricky thing for me was firguring out how to disconnect the wire harness from the sensor. A very secure connection, and elegant in its design.
The green tab needs to be pushed IN. (At first I wanted to pry up, or down, on it. Don't do that, you push it IN, until it clicks and locks)
After you push so the lock clicks, you can pull the wire harness off the sensor, and when you attach the harness to the new sensor, you push the harness until it's green tab pops out.

These little Nissan cars have the same sensor in a different place since they're transverse mounted 4 cyl. engines. You'll see yours at the back of the engine, where the transmission meets the engine, lying on your back under the car.

Video isn't helpful except it gives you an idea of what you're looking for. Use a large flat head screwdriver to push in that green tab.

http://www.youtube.com/watch?v=avZHC8qB0tI
 

·
Registered
Joined
·
250 Posts
You can get the cam sensor at Advance Auto Parts for $30.00 or so. Have them check your trouble codes to make sure it is not the crank sensor, which is a different sensor.
 

·
Registered
Joined
·
40 Posts
If the starter is clicking but the car isn't cranking, it's likely the battery is toast. The starter solenoid will click if there isn't enough power to keep it closed. I just went through this a couple of weeks back, battery died and it was so dead that it could not be jump started. It just clicked no matter how long I left the jumper cables hooked up. New battery fixed the issue. On a similar note, the FX is a very hard car to jump start. Don't try to jump it with a smaller car, there won't be enough juice to do it. I found this out the hard way and it took my friend's Nissan Titan to get it going the first time the battery died.

mikesd1980 said:
Im having this problem right now. Car is sitting on jumper cable hooked to my other car but it wont start and starter is clicking strong. My question is how to replace to the crank positioning sensor?
 

·
Registered
Joined
·
1 Posts
Good morning,

I hope someone might save me a tow to a mechanic. 2005 FX45 with 42,000 miles. Owned for two years, never any problems, until now...

Starter cranks, but engine doesn't start. Put new air filter in just to be safe (old one was pretty dirty). I'm pretty sure I hear the fuel pump when I first turn the key. Original battery which I will replace, but I have a good charger hooked up.

I turn the key and it cranks strong but no start. Any ideas?
Thank you,
 
1 - 10 of 10 Posts
Top