Infiniti FX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello All, Thanks for the feedback in advance...

I had my airbag recall, brakes, bearing, new tires and alignment done a few months ago,

The other day I was driving and my VDC OFF and Slip lights came on,
not my ABS light though. The mechanic gave me a C1143 code which is for the steering angle sensor.

I took it to the dealership and they reset/adjusted it free of charge and it worked for 3 days and went on again, now they say it needs a new SAS (steering angle sensor) and spring for $1600.


Another symptom I noticed that they said was fine, is that my car squeels when turning the wheels hard, like a bus's airbrakes when I make a hard u turn or am coming off an off ramp with a big turn.

Are the 2 related?,

Should I bite the bullet and get it fixed when it might not be the problem?

Should I just drive it without VDC (VDC Off and slip lights on)
Is that dangerous in snow rain, or is it just like driving an older car?
The car is 12+ years old but has only 91k miles.
 

·
Premium Member
Joined
·
10,995 Posts
Squealing when making tight turns sounds like your bearings are starting to go... I would look into that... Especially if you've never replaced them before (I think I've replaced 4 total... One of them twice... Front right I think...)
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Yeah, they replaced 3/4 bearings when I had my new brakes and tires put on a few months back. It makes a noise occasionally even when not turning, but braking.

Think it may have something to do with the all-wheel drive adjusting with the vdc off.

The fact that you usually you get a ABS light along with VDC Off and Slip lights , and I am not getting the ABS light is a big clue somehow..
 

·
Premium Member
Joined
·
10,995 Posts
Also check to make sure your brake fluid is in the acceptable range. Having low brake fluid throws codes as well but usually not this one...
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
yeah checked fluids, brake was good, PSF was a bit low added some, still squeels on turns and lights still on...
 

·
Premium Member
Joined
·
10,995 Posts
I would start looking for a 3rd party NISSAN / INFINITI that has a good reputation in your area... The platform was shared and many parts are interchangeable... The dealership usually has no idea what they're talking about, and on the off chance that they do know, they ALWAYS overcharge...

I still say the noise is from a bad bearing... Or they might have screwed something up when installing your other 3 bearings, but if the squeal always goes away when you brake, then it could also be brake related... There have been issues with brake squeal when I think it was the brake pad clips or something weren't reused, or it could be they simply didn't use enough brake lubricant...

So many possible issues...
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
The strange thing is have no ABS lite and the ABS seemed to kick in when testing it in the rain, If I truly had a bad SAS, wouldn't that be disabled as well as the VDC and SLIP


Also Im more worried about the VDC Off and Slip lights when the snow comes than I am the noise.
The noise only really happens on turns over 70 degrees, like curved off ramps etc. Couldn't this be a result of the VDC being disabled and the wheel speed not being adjusted? Its almost like the wheels are torquing on the pavement like it wants to skip over to adjust.
 

·
Premium Member
Joined
·
10,995 Posts
Remember that there are still 3 ABS sensors that are still working and that makes it all more confusing... I have ONE ABS sensor that failed (due to my own fault) that seems to have affected the ABS module... I'm still driving with a TON of lights on, but the ABS will still kick in if any of the other 3 sensors detect slippage... So even though you feel ABS kicking in, it doesn't mean it's not ONE of the sensors... Which again makes it so much more confusing... Right now, I believe my left rear area has an issue. I can't tell if it's bearing or brake related. Only squeals if I turn the steering wheel SLIGHTLY (or hard) left and usually disappears when I'm straight, or turning right... I took off the tire and checked the brake pads to see if I was low, but there's plenty of life left in the pads... And without doing anything else, the sound went away for 2 weeks... And now is back... I'll need to take it to my mechanic to confirm what exactly is wrong with her...
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
taking it in for 2nd alignment and SAS calibration, hoping it fixes it..
getting tires checked and rebalanced too.
 
1 - 9 of 9 Posts
Top