FX45 No Power When Warmed Up - Infiniti FX Forum : FX35, FX45 and FX50 Forums
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 09-06-2019, 07:01 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Location: Markham, ON, Canada
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
FX45 No Power When Warmed Up

I had my Y pipe bust off on highway and ever since the car is a gutless wonder after it's warmed up. Closed loop?


On cruise control, it slows down going up hill. It doesn't automatically downshift and give throttle.
Anyone have something like this?
Car has never had an engine light on since new (05)
123pugsy is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Today, 07:36 AM
Junior Member
 
Join Date: Aug 2019
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Transmission harness or connector may be damaged.
Maleficio is offline  
post #3 of 4 (permalink) Old Today, 01:26 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Location: Markham, ON, Canada
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Maleficio View Post
Transmission harness or connector may be damaged.

Thanks.

Transmission is fine. ECM not commanding throttle or fuel.



Dealer told me they found a code for knock sensors but they lied. They said that because they seen rodent twigs and stuff under the intake. $1430.00 to replace them so I told them to pound sand.



I ran the ECM reset procedure Sunday and I have at least 70-80% improvement. I'm hoping it's relearning and will continue to improve.
123pugsy is offline  
 
post #4 of 4 (permalink) Old Today, 01:37 PM
Junior Member
 
Join Date: Aug 2019
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
I'm gonna have to read up on this ECM relearn thing if it's any different from just disconnecting the battery for a half hour.
Maleficio is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Infiniti FX Forum : FX35, FX45 and FX50 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List




Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome