Infiniti FX Forum : FX35, FX45 and FX50 Forums

Infiniti FX Forum : FX35, FX45 and FX50 Forums (https://www.infinitifx.org/forum.php)
-   Engine and Drivetrain Problems (https://www.infinitifx.org/41-engine-drivetrain-problems/)
-   -   FX45 No Power When Warmed Up (https://www.infinitifx.org/41-engine-drivetrain-problems/36922-fx45-no-power-when-warmed-up.html)

123pugsy 09-06-2019 07:01 PM

FX45 No Power When Warmed Up
 
I had my Y pipe bust off on highway and ever since the car is a gutless wonder after it's warmed up. Closed loop?


On cruise control, it slows down going up hill. It doesn't automatically downshift and give throttle.
Anyone have something like this?
Car has never had an engine light on since new (05)

Maleficio 09-10-2019 07:36 AM

Transmission harness or connector may be damaged.

123pugsy 09-10-2019 01:26 PM

Quote:

Originally Posted by Maleficio (Post 308438)
Transmission harness or connector may be damaged.


Thanks.

Transmission is fine. ECM not commanding throttle or fuel.



Dealer told me they found a code for knock sensors but they lied. They said that because they seen rodent twigs and stuff under the intake. $1430.00 to replace them so I told them to pound sand.



I ran the ECM reset procedure Sunday and I have at least 70-80% improvement. I'm hoping it's relearning and will continue to improve.

Maleficio 09-10-2019 01:37 PM

I'm gonna have to read up on this ECM relearn thing if it's any different from just disconnecting the battery for a half hour.


All times are GMT -4. The time now is 03:11 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome