GPS/Radio display flashing w/ig off - Infiniti FX Forum : FX35, FX45 and FX50 Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 03-31-2019, 07:38 PM Thread Starter
Junior Member
 
Jeffro's Avatar
 
Join Date: Nov 2018
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
GPS/Radio display flashing w/ig off

Since I've owned my 08 fx35 my issues have been minor. Unfixable horn short and cruise control doesn't work with ACC. Tire sensor stays on after a flat this winter. It's tolerable.

Now at 130k there's one I've searched everywhere for and can't find anyone who's had or seen this on any Nissan or Infiniti cars. After I turn the car off, the gps/radio control screen begins flashing on and off with whatever was on screen last. Car still locks, unlocks and starts fine. I disconnected the battery overnight, tried turning the ignition on and off with the key in and jiggled every wire harness I can reach under the dash and hood. Right now I just disconnect the battery at night.

edit to add, and I live 60 miles from a qualified mechanic so I've always done all my own repairs.

Last edited by Jeffro; 03-31-2019 at 07:42 PM.
Jeffro is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-05-2019, 09:59 PM Thread Starter
Junior Member
 
Jeffro's Avatar
 
Join Date: Nov 2018
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
no clue exactly what did it 1. ran a jumper cable between the neg terminal to a large ground outside that car and unhooked the + cable. 2. slowcharged the 3 month old "super premium" Interstate battery overnight with the cables off. 3. After reconnecting the battery I reset all my trip/service/oil counters. One week and the display hasn't started flashing after the car is off anymore. Which is good because next I was planning on taking every fuse and relay out and putting them back in.
Jeffro is offline  
post #3 of 5 (permalink) Old 04-07-2019, 06:27 PM
Member
 
Join Date: Mar 2018
Location: PITTSBURGH, PA
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
Quote:
Originally Posted by Jeffro View Post
no clue exactly what did it 1. ran a jumper cable between the neg terminal to a large ground outside that car and unhooked the + cable. 2. slowcharged the 3 month old "super premium" Interstate battery overnight with the cables off. 3. After reconnecting the battery I reset all my trip/service/oil counters. One week and the display hasn't started flashing after the car is off anymore. Which is good because next I was planning on taking every fuse and relay out and putting them back in.
Never had nor heard of this situation before, but thanks for returning to post the remedy/followup! I've seen several threads on here where a problem was posted, but no answer was posted. Worse, I've seen some where a problem was posted and the OP returned to say the problem was fixed, but didn't share the solution. smh Glad your problem is fixed and you shared what you did.
kahlilj is offline  
 
post #4 of 5 (permalink) Old 04-17-2019, 04:10 PM
Junior Member
 
Join Date: Mar 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Quote:
Originally Posted by Jeffro View Post
Since I've owned my 08 fx35 my issues have been minor. Unfixable horn short and cruise control doesn't work with ACC.
What did you mean by unfixable horn....? I currently have a non-working horn and have planned to take it for repair next week. Does it mean you have tried to fix it without any solution? Mind you, the horn works when i lock the car but doesn't work on the steering wheel. I have searched all over for the solution but everyone i know had this problem never came back to post the fix.
lcsighte is offline  
post #5 of 5 (permalink) Old 04-17-2019, 11:12 PM Thread Starter
Junior Member
 
Jeffro's Avatar
 
Join Date: Nov 2018
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Quote:
Originally Posted by kahlilj View Post
Never had nor heard of this situation before, but thanks for returning to post the remedy/followup! I've seen several threads on here where a problem was posted, but no answer was posted. Worse, I've seen some where a problem was posted and the OP returned to say the problem was fixed, but didn't share the solution. smh Glad your problem is fixed and you shared what you did.
I've benefited (saved) a lot from motorcycle and car specific forums over the past 15 yrs or so and that bugs me too. Especially problems that had to get fixed somehow by someone, ya know?

Quote:
Originally Posted by lcsighte View Post
What did you mean by unfixable horn....? I currently have a non-working horn and have planned to take it for repair next week. Does it mean you have tried to fix it without any solution? Mind you, the horn works when i lock the car but doesn't work on the steering wheel. I have searched all over for the solution but everyone i know had this problem never came back to post the fix.
My horn is dead no matter what. No alarm beep and nothing on the wheel. I can put in a 30a fuse and it will honk for 1/2 sec before blowing what should be a 10 or 15a fuse with both alarm or honk. When I get a chance I'm going to take apart the wheel and column as far as regular tools will let me.
Jeffro is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Infiniti FX Forum : FX35, FX45 and FX50 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Slip, VDC off & ABS lights flashing - Car won't start J Gatz 1st Gen (2003-2008) 1 12-29-2012 12:57 PM
Radio display coming on at startup (but radio is off) SoCalGearHead Audio / Video / Navigation / Electronics 4 12-20-2007 02:49 PM
adding a gps to a non gps fx-35 rolff Audio / Video / Navigation / Electronics 2 10-29-2007 10:43 AM
Radio Display Head Unit and Center Console Removal gtxjoe 1st Gen 1 06-18-2005 06:12 PM
SAT radio display FXLENT Audio / Video / Navigation / Electronics 12 03-02-2004 03:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome