Air Conditioning problems - Infiniti FX Forum : FX35, FX45 and FX50 Forums
Reply
 
LinkBack Thread Tools
post #1 of 17 (permalink) Old 04-26-2010, 05:43 PM Thread Starter
Junior Member
 
Join Date: Jun 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Air Conditioning problems

Hey guys,

Sorry if this has been discussed but tried a search but didn't get too much.
So my 2007 FX is no longer blowing cold air. Haven't used the A/C in a while but it's been getting pretty warm and when I hit the button last week the air wasn't very cool or conditioned. I'm aware that I possibly need a refrigerant recharge. However I did notice that I didn't hear anything engage in the engine bay like I used to. Maybe it's just my imagination but I remember hearing a click after pressing the A/C button and the fans in the engine bay will work a little harder.

Any insight?
Thanks!
weaksauce is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 04-26-2010, 06:17 PM
Senior Member
 
johnmax's Avatar
 
Join Date: Jan 2004
Location: Long Island, NY
Posts: 10,641
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Send a message via AIM to johnmax
Re: Air Conditioning problems

Hmm first ive heard of this on the FX. You dont hear the compressor click on? Of course you should do the obligatory fuse checking routine (all 3 fuseboxes). Maybe a bad AC relay not turning the compressor on too.

Arent you under warranty still? If so let them fix it.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

03 FX45 Tech/Premium Liquid Copper Brick/Black, Viper 791XV alarm/remote start/GPS tracking, Nav-TV, XM, nav while driving mod, custom no nag nav mod, backup cam while driving mod, Stillen STB, Custom S550 LED mirror covers, Autolumination LED bulbs, Falken Ziex STZ/04s, Nissan Ipod interface w/80gig video, ORG sticker
johnmax is offline  
post #3 of 17 (permalink) Old 04-26-2010, 07:47 PM
Junior Member
 
Join Date: Jan 2010
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Air Conditioning problems

I had the same thing happen...Turns out a small rock had hit one of the lines on the compressor, and all the coolant had leaked out...If I'm not mistaken the compressor won't kick in (that's the click you hear ) if the coolant level falls below a certain level in the system..
moondawg51 is offline  
 
post #4 of 17 (permalink) Old 04-26-2010, 07:59 PM Thread Starter
Junior Member
 
Join Date: Jun 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Air Conditioning problems

Quote:
Originally Posted by johnmax
Hmm first ive heard of this on the FX. You dont hear the compressor click on? Of course you should do the obligatory fuse checking routine (all 3 fuseboxes). Maybe a bad AC relay not turning the compressor on too.

Arent you under warranty still? If so let them fix it.
I check out the fuses in the passenger compartment and they seem ok. Didn't touch any of the ones by the battery just because I'm not sure which fuse I'm looking for. Any ideas?

If I don't find anything by tomorrow I'll suck it up and make the long drive to the dealership.
weaksauce is offline  
post #5 of 17 (permalink) Old 04-26-2010, 08:02 PM Thread Starter
Junior Member
 
Join Date: Jun 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Air Conditioning problems

Quote:
Originally Posted by moondawg51
I had the same thing happen...Turns out a small rock had hit one of the lines on the compressor, and all the coolant had leaked out...If I'm not mistaken the compressor won't kick in (that's the click you hear ) if the coolant level falls below a certain level in the system..
Definitely no compressor engagement click then.
How'd you go about getting the problem fixed? Just handed it over to the dealership?
weaksauce is offline  
post #6 of 17 (permalink) Old 04-26-2010, 08:16 PM
Junior Member
 
Join Date: Jan 2010
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Air Conditioning problems

Took it to an A/C repair shop...Repaired the hole, charged the system..$275.00....Dealer wanted $975.00 to replace condensor and recharge...Told them no thanks...
moondawg51 is offline  
post #7 of 17 (permalink) Old 04-26-2010, 08:36 PM
Senior Member
 
psychopike's Avatar
 
Join Date: May 2009
Location: St. Albert, Canada
Posts: 918
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Re: Air Conditioning problems

Quote:
Originally Posted by moondawg51
Took it to an A/C repair shop...Repaired the hole, charged the system..$275.00....Dealer wanted $975.00 to replace condensor and recharge...Told them no thanks...
Yeah, you're almost always better off going to a dedicated A/C repair shop. If your fuses are OK then it's most likely a case of lost refrigerant. Same thing happened to our Maxima. Mind you, it happened after 16 years...

- Doug
'06 FX45 | Sport/Touring/Tech/NAV/DVD | Ivory Pearl/Wheat | +2 | JWT Pop-Charger |
'09 Murano LE STOCK - Glacier Pearl/Cafe Latte - DECEASED
2K10 Murano LE STOCK - Glacier Pearl/Cafe Latte
psychopike is offline  
post #8 of 17 (permalink) Old 04-26-2010, 09:10 PM Thread Starter
Junior Member
 
Join Date: Jun 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Air Conditioning problems

I'm still in warranty so we'll see what they say. Hopefully I won't be driving 45-60 minutes one way for nothing.
weaksauce is offline  
post #9 of 17 (permalink) Old 04-26-2010, 10:14 PM
Junior Member
 
Join Date: Jan 2010
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Air Conditioning problems

Mine is still under warranty...Said it made no difference since a rock had caused the damage...Hope you have better luck...
moondawg51 is offline  
post #10 of 17 (permalink) Old 07-23-2010, 07:11 PM
Senior Member
 
Truck11's Avatar
 
Join Date: Jun 2005
Location: Sterling, VA
Posts: 625
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Send a message via AIM to Truck11
Re: Air Conditioning problems

What color is the refridgerant? A hose busted and I now have green fluid which looks like radiator fluid right around the airbox area.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Truck11 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Infiniti FX Forum : FX35, FX45 and FX50 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
FX50S Noisy Air Conditioning rander 1st Gen (2003-2008) 9 05-17-2016 09:44 PM
MOOD AIR CONDITIONING everestgrant 1st Gen (2003-2008) 3 09-03-2012 10:49 AM
Air Conditioning Malfunction??? monica 1st Gen (2003-2008) 3 07-02-2010 10:05 AM
lexol cleaning and conditioning wipes??? chbak014 Detailing 2 12-30-2007 01:48 PM
Air Conditioning Question: Please Help MBHFX General Chat 25 12-31-2005 04:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome