Question about "Service Engine Soon" indicator? - Infiniti FX Forum : FX35, FX45 and FX50 Forums
Reply
 
LinkBack Thread Tools
post #1 of 14 (permalink) Old 05-05-2009, 09:25 AM Thread Starter
Senior Member
 
Join Date: Jun 2008
Location: Northeast Ohio
Posts: 154
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Question about "Service Engine Soon" indicator?

I have a question for all the experts here, two days ago, my "Service Engine Soon" lights came up while I was driving. I checked fuel cap, no issue there. I called dealer and the earliest appointment with loaner would be two days after, and was told it is still safe to drive as long as the indicator not blink.

Two days later before my appointment, the indicator went off. Does anyone had same experience before? What might be the cause for that? Is it still need to be serviced or just forget it?

Thanks in advance.

2009 Infiniti FX50S, Platinum Graphite/Graphite, Tech Pkg., Sport Pkg., Crossbar, Splash Guards (For me
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
2004 Lexus GX470, White/Iovery, Rear Seat Entertainment Pkg. (For wife
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)

Others in the past:
1987 Nissan Maxxma SE, 1989 Honda Accord Lxi, 1991 Nissan Pathfinder SE, 1993 Lexus ES300, 1996 Lexus GS300, 1999 Lexus RX300, 2004 BMW X5 4.4i, 2006 Audi A6 4.2Q
hzhao is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 05-05-2009, 10:41 AM
Senior Member
 
dislexicFXnaf's Avatar
 
Join Date: Sep 2004
Posts: 2,163
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Re: Question about "Service Engine Soon" indicator?

You put the gas cap on right (2 clicks) when checking it?

04 RWD-BS/Grph '35-Touring-railless-shaved-Ztek yback exhaust (PM me B4 buying Z-tek) Crawford plenum-ztube/sincity mod-JWT popper-lower billet grille-Stillen STB-20s w/Yoko ENVigors (3/11).
FINALLY on car: H&R Springs. Now on!!.. 20mm Ichiba spacers!
dislexicFXnaf is offline  
post #3 of 14 (permalink) Old 05-05-2009, 11:20 AM Thread Starter
Senior Member
 
Join Date: Jun 2008
Location: Northeast Ohio
Posts: 154
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Question about "Service Engine Soon" indicator?

Quote:
Originally Posted by dislexicFXnaf
You put the gas cap on right (2 clicks) when checking it?
Yes. Has always been that way.

2009 Infiniti FX50S, Platinum Graphite/Graphite, Tech Pkg., Sport Pkg., Crossbar, Splash Guards (For me
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
2004 Lexus GX470, White/Iovery, Rear Seat Entertainment Pkg. (For wife
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)

Others in the past:
1987 Nissan Maxxma SE, 1989 Honda Accord Lxi, 1991 Nissan Pathfinder SE, 1993 Lexus ES300, 1996 Lexus GS300, 1999 Lexus RX300, 2004 BMW X5 4.4i, 2006 Audi A6 4.2Q
hzhao is offline  
 
post #4 of 14 (permalink) Old 05-05-2009, 11:35 AM
Senior Member
 
imajeanius's Avatar
 
Join Date: Dec 2008
Location: York, PA
Posts: 291
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Question about "Service Engine Soon" indicator?

Best thing to do is to get it scanned. It could have thrown a soft code so even though the indicator light has disappeared, there might still be something that need attention. Chances are, if you don't get it looked at, it'll come back eventually.

Mine: 2004 VW Jetta GLI | APR 93/100 | FK Coilovers | 28mm rear sway | 35% tint | GHL CAI | 007 DV | 42DD 3" catless TBE | 6k HIDs | Hella Micro DE fogs | EIP 6 spd SS | and some other stuff
Hers: 2006 Berryllium FX35 Sport/Tech/Handsfree
imajeanius is offline  
post #5 of 14 (permalink) Old 05-05-2009, 11:37 AM Thread Starter
Senior Member
 
Join Date: Jun 2008
Location: Northeast Ohio
Posts: 154
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Question about "Service Engine Soon" indicator?

Quote:
Originally Posted by imajeanius
Best thing to do is to get it scanned. It could have thrown a soft code so even though the indicator light has disappeared, there might still be something that need attention. Chances are, if you don't get it looked at, it'll come back eventually.
Thanks for the suggestion. I will do that, and keep everyone posted with the result.

2009 Infiniti FX50S, Platinum Graphite/Graphite, Tech Pkg., Sport Pkg., Crossbar, Splash Guards (For me
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
2004 Lexus GX470, White/Iovery, Rear Seat Entertainment Pkg. (For wife
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)

Others in the past:
1987 Nissan Maxxma SE, 1989 Honda Accord Lxi, 1991 Nissan Pathfinder SE, 1993 Lexus ES300, 1996 Lexus GS300, 1999 Lexus RX300, 2004 BMW X5 4.4i, 2006 Audi A6 4.2Q
hzhao is offline  
post #6 of 14 (permalink) Old 05-05-2009, 11:57 AM
Senior Member
 
kieranlavin's Avatar
 
Join Date: Feb 2007
Location: East Stroudsburg, PA
Posts: 3,632
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Question about "Service Engine Soon" indicator?

It was probably the gas cap. Even though you checked it, the code was already thrown. I'm not sure what category it falls into but usually the light will reset itself after x number of starts. So if you get the check engine for the fuel cap and then start the car 15 times and it checks and finds no problem 15 times, it'll reset itself. I wouldn't worry about it or waste money having it checked out. You can check for a code yourself. There's a thread in the how-to about checking codes stored on the ECU. It's the same with the 09+ just that you have the push button instead of the 'nub'

douchebag extraordinaire
kieranlavin is offline  
post #7 of 14 (permalink) Old 05-05-2009, 05:09 PM
Senior Member
 
corvettedan22's Avatar
 
Join Date: Jan 2009
Location: Oxford CT
Posts: 266
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Question about "Service Engine Soon" indicator?

I also bet on the gas cap.

But it should store the code for a period of time so you can verify.

2005 FX35 Sport Package
corvettedan22 is offline  
post #8 of 14 (permalink) Old 05-05-2009, 06:34 PM
Senior Member
 
GJBenn85's Avatar
 
Join Date: Nov 2006
Location: East Coast
Posts: 2,054
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Question about "Service Engine Soon" indicator?

Quote:
Originally Posted by kieranlavin
It was probably the gas cap. Even though you checked it, the code was already thrown. I'm not sure what category it falls into but usually the light will reset itself after x number of starts. So if you get the check engine for the fuel cap and then start the car 15 times and it checks and finds no problem 15 times, it'll reset itself. I wouldn't worry about it or waste money having it checked out. You can check for a code yourself. There's a thread in the how-to about checking codes stored on the ECU. It's the same with the 09+ just that you have the push button instead of the 'nub'
Agree. This happened on my FX35 and after I cleared the light using the pedal method, it never came back. If the light is solid (not blinking), it is tied to the emission system including the fuel cap and is not a serious issue (per the owner's manual).

'10 QX56 - Current. $63k MSRP and no compass...?
'06 FX45 - Former
'05 FX35 - Former
GJBenn85 is offline  
post #9 of 14 (permalink) Old 05-05-2009, 08:55 PM
Senior Member
 
kieranlavin's Avatar
 
Join Date: Feb 2007
Location: East Stroudsburg, PA
Posts: 3,632
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Question about "Service Engine Soon" indicator?

Curious to know if anyone has actually experienced a flashing SES light aside from putting the car in diagnosis mode yourself?

douchebag extraordinaire
kieranlavin is offline  
post #10 of 14 (permalink) Old 05-05-2009, 08:55 PM
Senior Member
 
johnmax's Avatar
 
Join Date: Jan 2004
Location: Long Island, NY
Posts: 10,641
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Send a message via AIM to johnmax
Re: Question about "Service Engine Soon" indicator?

Not me.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

03 FX45 Tech/Premium Liquid Copper Brick/Black, Viper 791XV alarm/remote start/GPS tracking, Nav-TV, XM, nav while driving mod, custom no nag nav mod, backup cam while driving mod, Stillen STB, Custom S550 LED mirror covers, Autolumination LED bulbs, Falken Ziex STZ/04s, Nissan Ipod interface w/80gig video, ORG sticker
johnmax is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Infiniti FX Forum : FX35, FX45 and FX50 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
"AWD" light indicator bcheng4jc 1st Gen (2003-2008) 14 01-03-2013 09:59 PM
vibration with "service engine soon" light 93til 2nd Gen (2009-) 2 01-27-2012 02:13 AM
"Service Engine Soon" is on - what should I do? KPZerone 1st Gen (2003-2008) 6 10-02-2008 10:27 AM
"Lubricate all locks/hinges" bullet in 15k service Nick in WA General Chat 17 03-13-2008 09:10 AM
Reset "service engine" light?? forgot to plug in t SkyRat VQ35DE (FX35) 3 12-05-2007 11:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome