Service Engine Soon, Slip and VDC off all on at once - Infiniti FX Forum : FX35, FX45 and FX50 Forums
Reply
 
LinkBack Thread Tools
post #1 of 21 (permalink) Old 03-05-2009, 08:57 AM Thread Starter
Junior Member
 
Join Date: Jul 2007
Location: Concord, NC
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Service Engine Soon, Slip and VDC off all on at once

This has happened to me twice now. 2004 model with 38,000 miles. I come to a stop and then am not able to accelerate away. No power. The Service engine soon, slip and VDC off lights all come on. I have been able to roll very slowly but no amount of gas pedal pressure helps but the engine is still running. I stop, turn the ignition off and back on and then everything is fine with the exception of the Service engine soon light staying on. I have read some of the posts and will take a look a the brake fluid level etc. Any other ideas. Thanks.
Nchusker is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 03-05-2009, 09:29 AM
Member
 
Join Date: Jan 2009
Posts: 71
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Service Engine Soon, Slip and VDC off all on at once

Hi,
I had the same thing happen to me last week.
Took it to infiniti and they reset the computer. Two days later the same thing happened again..The mechanic said that if it comes on again they would have to do a total check. So far it hasn't come back on, but when it did, I still had all the power and acceleration..just annoying to see those lights on when u drive. Will let you know as my 06 Fx35 is at my mechanics shop getting the stillen stage 2 supercharger installed.

Any other questions feel free to share.

Sohail
Sohail is offline  
post #3 of 21 (permalink) Old 03-05-2009, 10:59 PM
Senior Member
 
IlovemyFX's Avatar
 
Join Date: Jun 2006
Location: Vancouver, BC
Posts: 1,485
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Re: Service Engine Soon, Slip and VDC off all on at once

If it's your brake fluid you usually get the brake light on as well. Take the car in to a local parts store and ask them to pull the engine codes. Many partsretailers do this as a customer service. Once you have the codes post them up or check up on them at infinitihelp.com:

http://www.infinitihelp.com/diy/obd_cod ... hart_2.htm

or at helpforcars.net:

http://helpforcars.net/obd_codes/

05 FX35, Silverstone, Graphite, Touring, Escutcheon, Sport Pedals, LED Dtrl's(thanks rookie), Stillen STB, +2 Timing, Stillen CAI, LMS Z-Tube, Grrrowwl!!, Plenum is next (OK - well - actually the G35 E-brake pedal is next, but I swear, something is going to happen with that plenum).
IlovemyFX is offline  
 
post #4 of 21 (permalink) Old 03-09-2009, 10:58 AM
ray
Senior Member
 
ray's Avatar
 
Join Date: Nov 2006
Location: Netherlands / Europe
Posts: 564
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to ray
Re: Service Engine Soon, Slip and VDC off all on at once

Did you loosen your steering wheel by any change...?? Or did something on your allignment....??

I had the VDC and Slip lights on as well and it was the steering sensor. When mounting my new Headers we had to loosen the steeringhousing a bit wich resultet in my steering wheel not being 100% right in the middle. There is a sensor picking this up and giving a signal by lightning up these Slip and VDC lights.

'03 FX35 RWD Nimbus Grey / Custom Koenigseder Bodykit / S6 DTRL 's / 22" Savini Forged 3 piece SV8 / 295-30-22 & 335-25-22 / Fully Build Engine with Turbonetics Kit and upgraded GT35R Turbo- 500Hp / Manual Transmission Conversion / 100% LED / BC Coilover / S.U.M.M.I.T. Strut & Brace Kit / JBT Brakes Front 380x6 Pot Rear 355x4 Pot / HKS Legamax / Audi RS4 Seats
ray is offline  
post #5 of 21 (permalink) Old 03-09-2009, 11:34 AM
Member
 
Join Date: Sep 2004
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Service Engine Soon, Slip and VDC off all on at once

Camshaft Position Sensor. With the frequency with which this issue seems to show up, I'm amazed at how often the dealer doesn't know what to do. My dealer (Glendale Infiniti in Los Angeles) recommended (by both the tech and the service manager) a cam replacement (or sprocket replacement) that he determined would be $7500 dollars (at least).

Went to an independent mechanic and had the camshaft position sensor replaced for a few hundred bucks and been working fine ever since.
surfsup is offline  
post #6 of 21 (permalink) Old 03-09-2009, 12:05 PM
ray
Senior Member
 
ray's Avatar
 
Join Date: Nov 2006
Location: Netherlands / Europe
Posts: 564
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to ray
Re: Service Engine Soon, Slip and VDC off all on at once

Quote:
Originally Posted by surfsup
Camshaft Position Sensor. With the frequency with which this issue seems to show up, I'm amazed at how often the dealer doesn't know what to do. My dealer (Glendale Infiniti in Los Angeles) recommended (by both the tech and the service manager) a cam replacement (or sprocket replacement) that he determined would be $7500 dollars (at least).

Went to an independent mechanic and had the camshaft position sensor replaced for a few hundred bucks and been working fine ever since.
**** that was some hard cash the dealer want to take out of your pocket.....!!

Didn't you put some sharper cams in it as well when all was open anyway i was thinking on other cams but it is quit some job to mount them

'03 FX35 RWD Nimbus Grey / Custom Koenigseder Bodykit / S6 DTRL 's / 22" Savini Forged 3 piece SV8 / 295-30-22 & 335-25-22 / Fully Build Engine with Turbonetics Kit and upgraded GT35R Turbo- 500Hp / Manual Transmission Conversion / 100% LED / BC Coilover / S.U.M.M.I.T. Strut & Brace Kit / JBT Brakes Front 380x6 Pot Rear 355x4 Pot / HKS Legamax / Audi RS4 Seats
ray is offline  
post #7 of 21 (permalink) Old 04-19-2009, 07:12 AM
Member
 
Join Date: Jan 2009
Posts: 71
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Service Engine Soon, Slip and VDC off all on at once

Quote:
Originally Posted by Nchusker
This has happened to me twice now. 2004 model with 38,000 miles. I come to a stop and then am not able to accelerate away. No power. The Service engine soon, slip and VDC off lights all come on. I have been able to roll very slowly but no amount of gas pedal pressure helps but the engine is still running. I stop, turn the ignition off and back on and then everything is fine with the exception of the Service engine soon light staying on. I have read some of the posts and will take a look a the brake fluid level etc. Any other ideas. Thanks.
Hey bud,

apart from checking your brake fluid, also check the water temp sensor..That caused my 06 fx to ignite the warning lights twice So far so good after changing the sensor...
Sohail is offline  
post #8 of 21 (permalink) Old 04-19-2009, 01:36 PM
Member
 
SoundFX's Avatar
 
Join Date: Jan 2004
Location: SLC, UT
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Service Engine Soon, Slip and VDC off all on at once

So I had a Service Engine Soon light a few days ago. No apparent problem, good performance, etc. but I hate unexplained warnings. Dealer checked codes and found some kind of "condensation" warning (don't you love when they won't say EXACTLY what it was...). Turns out the gas cap wasn't put all the way on (how embarrassing). They tightened the cap, reset the code, and so far all is well. Good thing, I'm driving to Vegas tomorrow...

So this begs the question...is there some kind of cheap code reader I can buy to read my own codes?? And with all of the technology in this car-WHY can't the codes just pop up on the maintenance screen of the monitor????

Good luck to Nchusker, hope you get yours sorted out soon.

03 FX45 Tech Blk/Brick ChrmWhls - hers
09 FX50s Tech Blk/Graphite - his - happiness is having two...
SoundFX is offline  
post #9 of 21 (permalink) Old 04-19-2009, 01:41 PM
Senior Member
 
johnmax's Avatar
 
Join Date: Jan 2004
Location: Long Island, NY
Posts: 10,641
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Send a message via AIM to johnmax
Re: Service Engine Soon, Slip and VDC off all on at once

Quote:
Originally Posted by SoundFX
Turns out the gas cap wasn't put all the way on (how embarrassing). They tightened the cap, reset the code, and so far all is well.
Geez you'd think after having 2 FXs you'd get this right by now... :P

Sears and Pep Boys usually have cheapo scanners.

Quote:
Originally Posted by SoundFX
And with all of the technology in this car-WHY can't the codes just pop up on the maintenance screen of the monitor????
Doesnt it sound so simple? Its like Apple not putting cut and paste on the iphone- it can read your heartbeat and everything else, but no simple functions that a Palm device from the 90's can do

I bet they dont put them there so you HAVE to go to the dealer to see what it is. They don't want any chance of you actually fixing your own car.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

03 FX45 Tech/Premium Liquid Copper Brick/Black, Viper 791XV alarm/remote start/GPS tracking, Nav-TV, XM, nav while driving mod, custom no nag nav mod, backup cam while driving mod, Stillen STB, Custom S550 LED mirror covers, Autolumination LED bulbs, Falken Ziex STZ/04s, Nissan Ipod interface w/80gig video, ORG sticker
johnmax is offline  
post #10 of 21 (permalink) Old 04-19-2009, 01:53 PM
Senior Member
 
DatMan's Avatar
 
Join Date: Nov 2007
Location: Ottawa, ON
Posts: 10,696
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 23 Post(s)
Re: Service Engine Soon, Slip and VDC off all on at once

Quote:
Originally Posted by johnmax
I bet they dont put them there so you HAVE to go to the dealer to see what it is. They don't want any chance of you actually fixing your own car.
And run the risk of them not making extra $$$ on your car...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2007 FX35 AWD Touring - GARMIN GVN-53 NAV mod, NAV-TV iPod music and video, PARROT MK6100, VIPER 5901 w/ SMARTSTART & GPS Tracking, Strong Strut STB, MD 5/16" Copper Iso Thermal, LMS intake w/ 3" K&N Cone, BC RACING Coilovers, GT SPEC Ladder Brace, STOPTECH SS Lines, 20" AVARUS AV1 w/ BFG KDW/2's, HAWK HPS Street Pads, 6K HIDs and 5K Fogs, LED lighting everywhere, Sport Pedals with ebrake, Escutcheon...
DatMan is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Infiniti FX Forum : FX35, FX45 and FX50 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
VDC OFF SLIP; Service Engine Soon alimer 1st Gen (2003-2008) 2 03-04-2016 06:55 AM
VDC slip light and service engine lights DragonViperSRT 1st Gen (2003-2008) 2 06-10-2011 01:50 PM
service today for service engine, VDC, slip lights on... johnmax 1st Gen (2003-2008) 32 01-07-2009 08:35 PM
Check Engine+VCD off+Slip lights came on FX-1004 1st Gen (2003-2008) 7 02-15-2007 11:02 PM
Service Engine Soon, SLIP, VDC OFF all light up jatavafx35 1st Gen (2003-2008) 27 02-25-2006 05:22 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome